Octolapse failing


#1

Hey everyone,

I am new to this so please bare with me. I have been trying to get my raspberry pi cam v2 to work with octolapse for the past week. I keep going through adafruit industries video, and cannot get it to work. I have tried other tutorials as well. I keep getting a bind 8080 failed message. I have tried moving things around as well, and I have even tried formating the sd card itself 3 times already. Sorry if the quality of the picture isn't the best. Hope someone has a fix for this.

Thanks so much,
Zachy


#2

Note the subtle error message above that "Address already in use". This means that you've got a running mjpg_streamer instance (probably) that's bound to tcp/8080 and you're attempting to do it a second time.

Learn to control processes on your computer. Run a ps -ax|grep mjpg to see if one is already running. Note the integer ID in the beginning of that report for the one that's already running. If it's 123, for example as a process ID, then kill it with sudo kill -9 123 in this case. Then try to run your mjpg_streamer using a different syntax if that's what you're trying to do.


#3

Ok so I did exactly this, and when I go for the kill command line it says that there is " no such process". Is that good? or Bad?


#4

So these are the commands I get when I try running it again. At first I got a webpage that was just black, and now I can't get anything. Thank you for your help!


#5

Uh... it looks like you got it to run and then you did a Ctl-Z (which puts it into the background but keeps it running). You would need to run fg (foreground) to bring it back into the foreground if you wanted to see the output.

If kill told you that the process wasn't running then you likely just typed in 123 from my example rather than typing in the number in your case which would be the far-left number in the earlier ps command.

You might find it easier to instead do: sudo pkill mjpg_streamer. This command will take out the guesswork.


#6

So I did in fact type in the number in the far left as per what you said. I will try the kill function and not use ctl-z this time. I didn't know that's what ctl-z does. I still have a lot to learn. Thank you!


#7

I'm SO used to Ctl-Z in the Windows world for undoing something that I accidentally did that once in a command terminal during a nano session. I was like wtf (where's my document)? :laugh:


#8

Hahaha thats hilarious. I do the Ctl-z all the time for stupid stuff, and it always messes me up idk why I do it though lol.


#9

Also starting to really lose hope on this. I reinstalled octoprint the other day, and even ordered a canakit psu. Now it won't even activate the camera. I don't know what's going on, and I have never used sudo code before so I am sorry if I am a little annoying with all of this.


#10

Okay, if you reinstalled OctoPrint I'm guessing you started over with a fresh OctoPi image. So, you'd need to visit sudo raspi-config and turn on the webcam under the Interfaces section, I'd guess.