OctoPi 0.15.0 (or 0.15.1) and RaspiCam on a Raspberry P 1B Rev. 2


#1

Hallo forum,

Since I flashed a SD card to OctoPi 0.15.0 (or OctoPi 0.15.1) I am not able to get images from my RaspiCam when I use both on a Raspberry Pi 1B Rev 2. When I use this setup on a Raspberry Pi 3 everything works fine - out of the box.
I know for shure, that:

  • the configurations are ok (at least for a Raspberry Pi 3)
  • the RaspiCam is ok and working
  • the Raspberry Pi 1B is ok and even the Cam is working on it as I use a Raspbian image and try to make pictures

The setup worked fine on earlier OctoPi versions.

I know a Raspberry Pi 1B is not very powerful, but it worked fine for me to manage my printer and do some remote control at home.

Is there anybody here able to help me? Thanks in advance.
Supermerlin


#2

If you provide your octoprint.log file, people can take a look at it.


#3

Here is the newest log files,

Which tool do you use to read the log file. When using Notepad it is only a long line of numbers, words and so on - no wordwraps. Is it possible to get on line for each log.
Edit: found a way - Notepad++

octoprint.log (8.3 KB)

Best Regards and thanks,
Supermerlin


#4

Have you turned on Access Control... and if so, have you logged in? It's possible that the webcam doesn't work in that case until you do. (I never turn on Access Control so I wouldn't know.)


#5

Yes - Access control is on, I am logged in.I have completely similar settings on the Raspberry Pi 1B and 3+. I can see the video on the 3+ but not on the 1B.

I have no idea how to solve it - thanks,
best regards, Supermerlin


#6

You might want to compare the /boot/config.txt for both.

start_x=1
gpu_mem=128

Just to be clear, the IE v11 browser doesn't like the webcam stream in OctoPrint.


#7

Yes - I have both settings in config.txt - I only use 192 MByte for GPU.

Here is config.txt as zip-file:

config.zip (996 Bytes)

Here is the octopi.txt as zip-file:

octopi.zip (1.3 KB)

Best regards, Supermerlin


#8

And here is the soluten to the problem:
It is a hardware problem on one of my Raspberry Pi 1B. What I have forgotten is, that when I flashed the new OctoPi image to the SD-Card, I also changed the Raspberry Pi 1B. I have 3 of them - on has coolers glued to the CPU and GPU - so I wanted to use this one - and this computer does NOT work with the RaspiCam, completely unimportant what I try - NO PICTURES COMING OUT OF THIS COMPUTER.

And I take a big learning: When having no idea why something isn´t working
==> try it on more than one hardware !!! (Sometimes the HW is the problem)

So thanks for the help, I will close this topic.

Best regards, Clemens