Octopi 0.16 + OctoPrint 1.4 + PiCamera Noir V2 stuck at 640*480

Sorry for coming with this kind of topics again, but honestly I don't know where else to look for a solution for this one...

In summary, after changing the octopi.txt with a desired resolution other than the "default" one, the change is ignored and the configuration stays in the good oldie 640*480 resolution.

Thank you very much in advance :slight_smile:

Camera model
PiCamera Noir V2

What is the problem?
Configured /boot/octopi.txt per documentation but still can not get resolutions greater than 640*480 on mjpg_streamer

What did you already try to solve it?
Followed several instructions on the forums and documentation.
htop shows that mjpg_streamer starts with the following:
./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_uvc.so -r 640x480 -f 10 /dev/video0

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
webcamd.log -> https://pastebin.com/Kxn1EYDi

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Octopi 0.16
OctoPrint 1.4
PiCamera Noir V2
Raspberry 3 B+

THere have been reports of some plugins like (if I remember correctly) Spaghetti Detective and OctoPrint Anyhwere messing with webcam settings, circumventing regular configuration control. If you have any of those installed I'd suggest to start digging there.

Thank you Gina. Sorry that I didn't mentioned in my original post.
I did some research on the plugins side. The only plugin (other than the default ones that comes with the standard release) is Telegram Notifications (v_1.5.0) and I don't think that this could be the issue. I tried to disabled it, rebooting octopi and I've the same behavior.