OctoPi 0.18 on Pi Zero 2 W doesn't work properly

What is the problem?

Tried to install Octo Pi on Zero2 following the instructions on OctoPrint.org - Download & Setup OctoPrint

When SW is started on Zero 2 there is some initial flickering of the green LED. After about 30 sec the LED remains off. Zero 2 can not be found as WLAN Device in my WLAN net.

What did you already try to solve it?

I used Raspberry Pi imager as well as balenaEtcher in combination with a downloaded .Zip file (octopi-0.18.0-1.7.2.zip)

I tried to insert my WLAN data in Pi imager (Ctrl-Shift-X) as well as in octopi-wpa-supplicant

I just flashed the very same file (configuring the wifi via Ctrl+Shift+X):


Booted a Zero 2 from it:

And it works:

Are you sure the flash worked correctly? Are you sure you entered the credentials correctly? Is the SD card ok? Is the Pi booting other images? LED stays more or less constantly on during runtime after initial boot.

Plugging it in to a HDMI monitor is usually the best way to diagnose boot problems.

Admittedly the Mini-HDMI connector on these things makes this a bit more cumbersome however, I had to order a new adapter last week because the one I had has managed to hide itself very well somewhere.

I nailed it. It was a weak power-supply with only 2Amp. Changing to an original Apple Supply (where the ratings are so small that i can't read them) solved my problem.


Thanks for your help.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.