Octopi .14 won't work with Pi3B+


#1

Hi
In just loaded up .14 on the new model Pi3. It boots up and I get the rainbow screen. I rebuilt the image twice and had the same result. So I tried raspbian and it worked fine.

Thanks
P


#2

#3

Suppose I'll try to enable the GUI on my other pi3B that's running octopi and put this 3b+ to another use. I'm new to octoprint and having problems getting a vpn on octopi. So I guess I'll put TeamViewer on octopi.

Thanks
P


#4

In general it is preferable to put the VPN server not on the same machine you are running infrastructure on. If someone were to DDOS your VPN server, they'd also DDOS your print server in the process.

A lot of routers these days come with built in VPN support, I suggest to take a look at that.


#5

Thank you. I'll take a look. Loving octoprint. Thank you for developing it :+1:


#6

Here's the image to use: https://github.com/guysoft/OctoPi/issues/505


#7

There is also another way to use the 0.14 image if you have an existing setup and do not want to re-do everything.
This assumes:

  • You have another pi (any version before 3 B+ will work)
  • You can SSH into the pi over the network
  • You have a valid backup of your SD card, because this completely upgrades the underlying OS
  • You do not blame me for anything lost or broken in the process!

This was mostly taken from: raspberrypi.org

Boot up the OctoPi 0.14 image

SSH into the pi and run:

sudo sed -i -e 's/jessie/stretch/g' /etc/apt/sources.list
sudo sed -i -e 's/jessie/stretch/g' /etc/apt/sources.list.d/raspi.list
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Both the upgrade and dist-upgrade will take a while.
The upgrade process may ask to change files. Unless the file is haproxy.cfg, enter in 'yes', 'y', or select the 'Install package maintainers version'.
You do not want to overwrite haproxy.cfg!

The upgrade process may also show a full screen of text. You can skim through it with the spacebar if you want, or press 'q' to quit.

You may also need to update your wpa_supplicant file to reference the correct country code.
You can use sudo nano /boot/octopi-wpa-supplicant.txt, or edit the file offline on another computer.
Or for lazy people like myself, you can use sed, just make sure to update to the correct code:

sudo sed -i -e 's/^country.*/country=US/g' /boot/octopi-wpa-supplicant.txt

Finally you can shutdown and swap the SD card to the 3 B+

sudo shutdown -h now

I just went through this process on a fresh install of 0.14 with a 2 B and a 3 B+, so your mileage may vary.