Octopi 3b+ won't connect to network

What is the problem? The new pi 3B+ won't connect to network thru wifi or ethernet

What did you already try to solve it? First tried wifi then ethernet. I tried the whole procedure multiple times, tried two different micro sd cards (Samsung 32GB and samsung 8GB). used etcher to flash the .img file, used Notepad ++ to edit the .img file, even bought a dedicated 2.5amp power supply.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

ssh pi@octopi.local
ssh: Could not resolve hostname octopi.local: No such host is known.
ifconfig wlan0
'ifconfig' is not recognized as an internal or external command,
operable program or batch file.
Ran Advanced IP Scanner>>> Doesn't show octopi
Logged into my router>> octopi doesn't show up in clients
Repeated the whole process couple of times tried wifi as well as ethernet.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

octoprint version 0.17.0
raspberry pi 3B+
tried on desktop windows 10 64bit and laptop windows 10 64bit
Cannot connect monitor to the raspberry pi because my monitor has DVI connector.
I still have not connected my Ender 3 Pro to the pi yet.
I will any guidance and help. Thankyou

2020-04-29T04:00:00Z

Hi, did you edit the wlan parameters in the supplicant file? You need to enter your ssid, password and uncomment your country for the wireless to work.

Thanks for looking into and helping.
Yes I did using Notepad ++

WPA/WPA2 secured

network={
ssid="myssid"
psk="mypw"
}
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States
I checked and double checked. Connected with ethernet cable also, withing 5 feet of router.
Also, I am connecting to 2.4 GHz network and not 5GHz, (Both pi and computer)

If connected via Ethernet do the green and yellow lights on the Pi's RJ45 light up?
Log onto the router and look for a machine called octopi - it must appear in the DHCP lease table.

If the lights on the RJ45 don't light and its not in the DHCP lease table, try another cable, its not unknown to have damaged ethernet cables.
If it has an IP address, on first boot into Octopi it takes a while. But from any other machine, ssh to the Pi, if you have windows, get putty, its a must!.

If you have a linux machine simply, from the terminal / command line, type ssh pi@octopi and hit return.
First thing you MUST ALWAYS do is change the password, its the default pi account password, 'raspberry' all lower case, no quotes :-).
you do this by typing at the prompt passwd then hit return, choose a new password - you'll need to enter it twice.
Its just occurred to me, if you ALREADY HAVE an octopi, they CANNOT have the same name - it gets awfully confusing so do this: - after logging on with ssh....

type 'sudo vi /etc/hostname' and press enter - you will be asked for the new password you just changed with the passwd command
vi is very cryptic but worth learning so follow the next instructions to THE LETTER. If you make any mistakes, hit : then type q! and press enter, this is vi speak for q(uit and don't ask any questions. If you forget to use sudo vi, it will only open /etc/hostname as readonly, which isn't much help - but you can still :q! out,.
type dw, thats the vi command to d(elete w(ord
then type i, thats the vi command to i(nsert
then type your new hostname, e.g. octopi-2
then hit the 'esc' key, that's the vi command to stop inserting
then press : that's the vi command to drop to the colon prompt - it has a proper name but I don't know it without looking it up
then type wq thats the vi command to w(rite - the file and q(uit
yes its cryptic, but its on EVERY UNIX machine almost EVER. so once learned never forgotten.

then type sudo reboot now

If you already HAVE an octopi, do this on the Pi that is already working, then do it on the new one, ALWAYS change the pi account password every time you build a new pi micro sd card. Obviously don't reboot if you are in the middle of a print :slight_smile:

Thanks for looking into it. When I connect pi with eathernet cable the RJ45 jack lights up orrange and blinks intermittently. I tried multiple eathernet cables. Tried on two copmuters (a wired desktop and wireless laptop on windows 10), logged into router as well as ran Advanced IP Scanner. Octopi or something similar doesn't show up any place. This is the only pi I have, first time user. I have given upto 20 minutes after powering the pi up. Thanks again.

OK, The lights look and sound fine. normally these things work straight out of the box, if you are not finding octopi as a hostname, that suggests a problem with the SD card - if you have another micro SD, try create another micro SD card with Raspbian desktop and plug the pi into a TV with a standard HDMI cable, if you can. What are you using to write the micro SD?, There's a tool on the raspberry pi.org website that will download and create a new micro SD - all it asks you to do is choose which Raspbian image you want - you could do that over the card you are using for octopi and when we've got the pi working we can try an octopi image again. I'm going to put a known bad microSD in one of my pi's. Don't give up, we can fix this.

This is the new Raspbian imager https://downloads.raspberrypi.org It works. Or use Rufus, which is a bit harder to use, but is REALLY good. I've tried Etcher and hated it.

This is Rufus https://rufus.ie/

Thanks again. I burnt another working micro sd card using your suggested img on downloads.raspberrypi.org. Connected pi to the TV with the SD card and ethernet, still pi doesn't show up when logged into my router and also ran advanced IP scanner. You think it could be just a bad pi card ? I am attaching image of what I see on tv when pi attached to it.

When it's connected to the TV and boots, does it show an IP as the last step?
You're connecting to one of the number ports 1-2-3-4 on your router and not the WAN port?

Ethernet with cable is always a good place to start, I couldn't get WPA-supplicant to work properly despite having done it hundreds of times with normal Raspian installs.

Does Bonjour work on Windows to use pi@octopi.local, or would you have to use pi@192.168.1.5 (or IP of pi, obviously).
You might be worth trying to ping octopi.local first, and pinging the IP address if you find it.

Thanks thoward. Connected to TV when pi boots, no IP shows up. Earlier I was connecting one of the Ehernet ports on the router. Now even connected to the modem directly, still no success. Pi doesn't show up when I login the router nor when I run Advance IP scanner. I am lost !

OK, I think you might be right about the Pi, a Kernel Panic is NOT GOOD!. That means the core of the operating system has fallen in a heap. If you downloaded a fresh Raspbian build using the Raspberry Pi imager and you got that string of errors, that can mean only a few things::

  1. The Raspbian build image is corrupt - possible but unlikely if the imagerr downloaded a new one;
  2. The microSD card is damaged - did you try a new one?
  3. Finally the Pi might have some problems:
    A. have you used it for any other purpose - connected something to the GPIO
    B. When you tried it - were any other devices plugged in - remove everything but the power connector and the HDMI, then retry.
    C. If its still throwing a kernel panic, then the only conclusion is the Pi is dead - if its straight out of the box from whoever you bought it from, ring em up and send it back - especially if it was bought from a reputable supplier of Pi's, in the UK I only use Pimoroni and ThePiHut - too many people on eBay think its a good idea to sell a dead Pi for £15, I contacted one a couple of weeks ago and the seller said, in answer to my questions, 'no these are dead' if they are dead they are only good for recycling and not worth 15p. Sadly buyer beware. A PiZero will boot from the same Micro SD card BTW - if you are trying to eliminate the card or the Pi.
    Sorry I can't be more help, but generally a kernel panic is not good! - They are VERY rare on a working Unix system, unlike a Windows BSOD.

Thanks again rcw88. I tried on two different working sd cards (I can read and write to them). Only hdmi, eathernet and sd cards were plugged in during booting etc. And this is a brand new pi and was never used for anything else. I bought it from amazon and they have authorized a return. Now I think I will order another pi, I am still going to keep the old one till I get the new one incase any other suggestion comes to mind, still open to it. Thanks again

All right guys, I should change my name to "Stupid". I was inserting the micro sd with an USB adaptor in the USB slots. I noticed the micro SD slot when I was browsing to order a new pi on Amazon. When I used the real micro sd slot in the back, it connected to WiFi, no issue. Sorry and thanks again.

1 Like

No problem, we all have to start learning somewhere, don't ever do what I have done and try to remove the Pi from a case with the SD card in - I use the Lego style cases a lot - removing the Pi with the SD card in breaks the sd card holder off the pi, then you really ARE in trouble.