Octopi and Neopxiel Ring on Raspberry Pi 4

What is the problem?

I am running octopi on a raspberry pi 4. My Pi has a neopixel ring connected to it.
I am trying to get the neopixel ring to start when the pi boots up.
My regular pi works fine. I believe the service which starts the neopixel ring
service is being stopped by asking for a passwrd i,e,

i@octopi:~ $ sudo systemctl start ledshim.service
[sudo] password for pi:
for the service

Is there anyway to allow this sevice to start without enntering a password.

cd /lib/systemd/system/
sudo nano neopixel.service

sudo chmod 644 /lib/systemd/system/neopixel.service
chmod +x /home/pi/ rpi-ws281x/examples/strandtest.py
sudo systemctl daemon-reload
sudo systemctl enable neopixel.service
sudo systemctl start neopixel.service


Hello @Rav_Khangurra !

You may have a look on this:

I would recommend using this plugin for controlling WS281x LEDs from OctoPrint - no configuration needed outside OctoPrint:

(Small disclaimer, I am the author there :slightly_smiling_face:)

To run without a password, you would have to configure passwordless sudo. This requires editing the sudoers configuration, and there should be many guides you can find to configure sudoers.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.