Octopi and Raspberry Pi 3 Model 3 V 1.2 not connecting


#1

I've tried 3 different SD cards with Octopi written to them with Etcher and Win32disk tool. I setup wifi, and tried connecting to Ethernet and nothing is showing up when I ping Octopi.local or try to SSH in with Putty. The lights are flashing green on the Ethernet port. I cannot find the Octopi on my Network at all.


#2

You'll need to connect it to a monitor.


#3

I was able to track down the IP and get connected to it over Ethernet, but I'm pretty sure WIFI is still not working.


#4

ah, but if you are connected, it's a lot easier to debug!

You can look for the wifi details here- basically, the wlan0 entry. If it doesn't have an IP, paste the ifconfig output and your config entries and we'll troubleshoot.


#5

I managed to get everything communicating, and have forwarded the port that the Octoprint is on.

Is there a way to change connection settings from inside octoprint? I need to make the IP static so it doesn't change on a reboot.


#6

octopi.local will not work on a Windows machine unless you install Bonjour for Windows in your windows PC (Macs and many Linux distributions have this installed by default)

You might find it in the Windows Network pane - but I've not accessed OctoPrint from a Windows PC, so can't be much help there


#7

I reserved an IP on my router. Octopi.local isn't working (even though bonjour is installed), but that's not really a big deal. I think I've got it mostly figured out. Thank you.