Octopi and usb webcam

What is the problem?
The webcam it does not work with this command octoprint launches "./mjpg_streamer -o output_http.so -w ./www -n -i input_uvc.so -r VGA -f 1 -y
What did you already try to solve it?
I suspect it is the -n flag, because if I run the command manually without the -n flag everything works
How can I change the command that octoprint launches?

Thank you

  1. It most certainly is not the -n because all that does is disable the commands page on the web interface.
  2. "Doesn't work" is too vague to be able to help you.
  3. OctoPrint doesn't launch your webcam server, it's the webcamd service on OctoPi that does that. It's log is at /var/log/webcamd.log and you really should share that if you want others to be able to help you. See also this FAQ entry: https://discourse.octoprint.org/t/where-can-i-find-octoprints-and-octopis-log-files/299.
  4. FAQ entry on changing webcam parameters: https://discourse.octoprint.org/t/how-can-i-change-mjpg-streamer-parameters-on-octopi/203?u=foosel
1 Like

You're right, it was not the flag -n I solved this way, I edited the file /boot/octopi.txt and I removed the comment to the line "additional_brokenfps_usb_devices" and I entered the value from the "lsusb" command.

For example,

myocto@octopi:/boot $ lsusb
Bus 001 Device 004: ID 0c45:6340 Microdia <---- THIS IS MY WEBCAM

Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

myocto@octopi:/boot $ cat /boot/octopi.txt

additional_brokenfps_usb_devices=("0c45:6340" "aabb:ccdd") <---- THIS IS THE MODDED LINE


I hope he can help someone.

Bye Thank you.

Can you please post the name of your webcam?

Have you searched for your webcam in https://github.com/foosel/OctoPrint/wiki/Webcams-known-to-work and used some parameters found there in your configuration?

I was able to setup my new webcam using this list and the parameters in minutes.

The webcam is a Trust Spotlight Pro.

When looking in to the list of tested webcams, you can see that a webcam named "Trust Spotlight" was used with the parameters "-r VGA -f 1 -y".
This webcam has a chip with a resolution of 640x480 pixels. The pro webcam has a chip with 1280x1024 pixels, so its possible the VGA-resolution will not work.
Perhaps you can try to change VGA to 1024x768 or 1280x720. I am not sure if 1280x1024 is a supported parameter, but you can try it, too.
You can also try to change the -f - parameter to 15 or 30, this is the framerate. The -f 1 sets the framerate to one picture per second, and not every webcam can support this.
Best is to try combinations of the -r and -f parameters until you can see a result.