Octopi can't be found on my network

What is the problem?

Octopi.local can't be found.

What did you already try to solve it?

I downloaded Raspberry Pi Imager and installed it on my windows 10 pc. I run it choosing Octopi OS I do cntrl+shift+x I enter the SSID of my wifi and it's password plus my location US. I choose write to the SD Card(which I have formatted) The imager write to the SD card and verifies and completes. I then check the file octopi-wpa-supplicant.txt and nothing has been filled in it's just the file with all lines commented out:



ssid="put SSID here"


Also the country is still GB

So I edit the file using Notepad++ putting in the wifi password and ssid and US as the country and comment out GB.
loaded the sd card into my new raspberry pi 4B and It does not show up on the network. I have run Angry ip Scanner and it doesn't show up. I have Octopi running on a laptop but want to use the Raspberry Pi
By the way I also ran the imager to install Raspberry Pi OS and checked the file First-Run and in that file I found it did write in the country as US and also had the correct ssid and password(?encrypted)

What do I do now?

Have you tried running in safe mode?


Did running in safe mode solve the problem?

If I cant find it on the network how do I run in safe mode?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Octoprint version is whatever version Raspberry Imager puts on the sd card I guess it's the latest as of Oct.28,2021

Additional information about your setup

Doing the above Im on Windows 10 using chrome
OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


That option is not really supported by the octopi image, because the wpa file got a different name.
Tbh I wasn't even aware of that option screen :smiley:

I would try it again with all pi imager settings on default to make sure that the additional file doesn't mess with the settings.

Did the wifi work with that Pi OS image?

edit: I was wrong - those wifi settings should work - my bad :slight_smile:

The imager works by creating a firstrun.sh script that fills in the wifi details for you, so this:

is expected behaviour until you boot up the Pi.

If you then boot it, it should connect to the wifi without you touching the file yourself. The details will be filled in, and it should contain the necessary information in the file.

If you are having trouble connecting it to wifi, see if you can connect the Pi using HDMI with a keyboard, so you can poke around to see why it may not be connecting to the network.

The problem must have been the BL Touch cable Longer sent me a new cable and it is now working.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.