OctoPI "can't connect to internet with wireless bridge"

What is the problem?

I'm trying to run OctoPi on a Raspberry Pi Model B V1.1 along side a TP-Link AC1750 setup as a wireless bridge. When I go to install plugins, it gives the following error:

Unexpected error while trying to install plugin from None

and up in the top toolbar, it also tells me:

There is no connection to the internet

I connected the Pi to my main router (via ethernet), and was able to install plugins, connect to a mobile app, ping googles "" on port 53, and such, but when connecting it back to the bridge, it can't ping them. When I connect my laptop to the wireless bridge (via wifi/ethernet), I'm able to access the internet.

What did you already try to solve it?

1: Watched a YT video on setting up the TP-Link router in wireless bridge mode
2: Tried resetting the router fully
3: Tried rebooting, resetting, & reinstalling OctoPi on the Raspberry Pi

Have you tried running in safe mode?

I have not since I was having this issue before any third-party plugins were ever installed.

Did running in safe mode solve the problem?

Not relevant

Systeminfo Bundle

octoprint-systeminfo-20230621044610.zip (109.2 KB)


Raspberry Pi: Raspberry Pi 2 Model B V1.1
Router: TP-Link AC1750 in wireless bridge mode
OctoPrint Version: Version 1.9.0

Please let me know of any additional info that would be of help!

Thanks in advance for the help!

First thing we need to do is be able to ssh directly to your Pi's command line, to do that you will need to have enabled SSH on the Pi's operating system, this is going to be useful..
Some tests to try:
Does the Pi's networking stack get an IP address when it is connected to the bridged network? - you should check your DHCP server when its on your main network and when it is attached to the bridged network, try pinging the device.
Does any other machine work [using a DHCP address] when on the bridged network?
Can you connect to the Pi when your laptop is on the main network and your Pi is on the bridged network?
Pinging tests IP connectivity, not DNS so try pinging google.com, if that doesn't work then the problem will probably be DNS Name Resolution [it often is, because of the way Debian/Ubuntu are set up with a new install]

Name resolution, for some bizarre reason, Raspbian is not set up to use DNS properly out of the box, there is a 'legacy' [because its been around forever] network configuration file which controls how the Pi [and all other Debian/Ubuntu Linux/Unix systems] does network name resolution. For simple networks it usually works fine as its set up to use mDNS responder, aka Avahi, but on complex networks this breaks, so you need to change the config file. mDNS is based on Apple's Bonjour/Rendezvous invention, for background, read this.. https://en.wikipedia.org/wiki/Bonjour_(software)

We are going to edit the config file on the Pi's micro SD card - the file is /etc/nsswitch.conf

The culprit is the line starting hosts, yours will be

hosts: files mdns4_minimal [NOTFOUND=return] dns

Note the sequence - files - meaning the Pi's local /etc/hosts file - the Pi's IP stack will look there first.
mdns4_minimal - meaning use Multicast DNS, aka Avahi
your file will then have [NOTFOUND=return] then dns

What that means is that normal dns lookups are NEVER performed because dns is AFTER the [NOTFOUND=return] so:
Using a line editor, insert dns before the [NOTFOUND=return] so the line reads like this

hosts: files, mdns4_minimal dns [NOTFOUND=return]

Reboot and then try pinging google.com. I change the connectivity check box on my Octoprint instances to use a name, not an IP address, then it proves DNS is working properly.

This is one link explaining what is going on in a bit more depth..

Windows is different [naturally, because for decades Microsoft never followed RFC's properly, they bought in IP stacks for windows, then finally wrote their own based on the BSD stack] https://epicentras.wordpress.com/2016/06/03/difference-between-ping-and-nslookup-name-resolution/

Somewhere I've got a link to an excellent post on the subject which I will attach, ITS COMPLICATED, but mDNS makes it simple, most of the time...

1 Like

Have you gotten your pi to connect to ANY WiFi? Wondering if it's just the bridge, or if it's any wifi connection.

You might try some of the troubleshooting at this link to see if you Pi can even see the bridge and if so, is it connecting to it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.