OctoPi can't find hidden SSID

Hi all!
This is the first time I am trying to run OctoPrint and I just can't get it to connect to my network.

I installed it onto the SD card with ease, wired the Pi 3B directly into my router and SSHed into it. I got into raspi-config and gave it the information needed to connect to my WiFi. I had the SSID of my router turned on while I did that to make sure that it could see it. I rebooted the pi, disconnected the Ethernet cable and watched from my router config to see if it could connect wireless and it did. I then opened up OctoPrint on my browser using the IP. I went through the startup wizard and I ran the update. After rebooting from the update, the pi connected to the WiFi again.
I then shut the pi down, disconnected it from the power and took the SD card to my computer to edit the octopi-wpa-supplicant text file, so I could add the line "scan_ssid=1" after the password to allow it to find the router after I turned the SSID back off.
To my surprise, the SSID and WPA password for my router wasn't in the text file and the lines were still commented. OK! Whatever?! I uncommented the lines, added my router info and added the new line to find the hidden SSID.
Then I put the SD card back into the Pi and booted it back up after turning my SSID off aaaaaand... it isn't connecting to my WiFi and I have no idea why.
I even went a step further and even told my router to give the Pi a static IP address.
I have tried looking around here for a few days to try and see if anyone had the same issue in the past, and I didn't find anything.
Now I am clueless as to what could be going on here.
I really don't want to broadcast my SSID just to run OctoPrint. I would rather find a way to fix this.

I would greatly appreciate any help that anyone could lend me.
Thanks!!!

Try this troubleshooting guide.

I cannot get Octoprint to connect to hidden SSID following the throubleshooting steps provided. If I remove the Hidden SSID chechbox in my Asus Router it connects without issues.

I´m running the latest OctoPi image and this is my settings:

WPA/WPA2 secured

network={
ssid="MyWifi"
psk="MyPassWord"
scan_ssid=1
}

I see a lot of posts about this, but not a lot of confirmations about people getting it working with hidden SSID?

Know I'm kind of resurrecting this post, but I found it via Google, and figured I'd update with how I fixed this for the next person that Googles it.

After editing the network file manually, I had to add the line "key_mgmt=WPA2-PSK" under scan, so like this:

network={
ssid="MyWifi"
psk="MyPassWord"
scan_ssid=1
key_mgmt=WPA2-PSK
}

And once I did, it's been connecting to the hidden network just fine. Hope this helps the next guy.