Octopi Connecting to Wifi, but can't ssh, or ping

What is the problem?

Raspberry Pi 4 flashed with octopi 0.18.0 connects to WIFI (checked router), but I can't ping, SSH or access octoprint through browser.

Pinging from my windows computer gives:
Pinging with 32 bytes of data:
Reply from Destination host unreachable.

However, I can successfully ping google.com from the raspberry pi.

The raspberry pi with octopi does not show up in networking scans (Fing from my phone, and nmap from my Linux laptop).

What did you already try to solve it?

It was originally my Raspberry Pi 3 that stopped working, I tried on another 3 and 3B, before buying a Raspberry pi 4 and that didn't work either. This is especially frustrating because it previously had been working for about a month until it suddenly stopped and I can't get a new one up and running using the same process I've used dozens of times.

I've tried logging into my router, and changing the ip to be reserved, it didn't seem to change anything. I've tried creating an ssh file in /boot. I've swapped to new sd cards and changed to a power supply that came with a cana kit, got a brand new raspberry pi 4. At this point, I'm stumped as to why connecting to it has become such an issue, and need some help from people that understand networking better than me.

The only thing that I can think of is that something with our xfinity wifi changed and now it doesn't like the device and is somehow blocking it. But there is no indication of that, I just can't think of a reason why it would suddenly become impossible to setup a raspberry pi on our network.


dmesg output: https://drive.google.com/file/d/12DdqNTrTw4B_tAw1LgwDXMoASxyGRYXs/view?usp=sharing

Additional information about your network

Our provider is Comcast Xfinity and our gateway is an Xfi Gateway 3rd Generation (CGM4331COM).

I would greatly appreciate some help, because at this point I'm completely stumped as to what to try next.

Hello @cdsupina !

Do you have the chance to try with Ethernet cable?

You also can connect a HDMI TV/monitor to the Pi. At the end of the startup sequence you will get the actual IP address of the Pi.

If you can see the device is connected and the Pi can ping the internet it sounds like the router is doing some client isolation thing. The name varies from router to router but make sure you aren't using a 'Guest' mode, and no isolation settings are enabled. Otherwise it will block the devices on your network from communicating directly.

I have connected a monitor to the pi. And I 100% know it has a connection to the internet, I can ping google (from the pi), see the ip address, and see it connected to our gateway through our gateway's interface.

The issue is that I can't ssh into it or ping it from another device connected to our local network.

I'm trying to locate client isolation in my gateway, but I'm not seeing anything so far.

I got it working, but it doesn't make any sense to me why this worked. I plugged directly into my gateway with an ethernet cable. I could ping and ssh into it this way. Then I unplugged it from ethernet and tried pinging and sshing with a wireless connection again and it worked. ¯_(ツ)_/¯

I'll take it. I hope this is able to help others. And make sure to post here if you think you know why this happened.

Im having exactly the same Issue as you here.
Did you set a fixed IP Address for your Pi? After rebooting its still working?

I havent found a solution yet, but I will try the same way you did.

Im using a DD-WRT Router and do not know about any net isolation.

Thank you so much for posting this solution. I had a very similar problem where my rpi4 was connected to my router via ethernet, and after a power blip, I was able to access the internet through my rpi4, but I could not ssh into it or ping the rpi4 from another pc.

After unplugging the ethernet cord and connecting to wifi, I was able to ssh into it, and then after reconnecting back to ethernet, everything worked again.

Again, thanks for sharing, I was very close to wiping and doing a fresh install.