Octopi connection problems on rpi Zero W

Hi forum,

Im an new octopi user and im currently trying to upgrade my second printer (Prusa i3 Mk3) with the Rpi Zero W.
I know i know, the Zero is to slow and so on, but im just planning to use it for remote control no camera no plugins planned and a lot of people seem to do so succesfully, and the einsy board connects via GPIO Header to the Zero, wich keeps everything clean.

The problem is i cant get my Zero to connect to my wifi. I can neither get octopi.local to connect, nor do i see the octopi my routers interface.
I configured the "octopi-wpa-supplicant.txt" file as i did on my rpi 4B (Anycubic Chiron) where everything works fine.

  • i already tried reflashing the firmware. (BalenaEtcher run on Win 10)
  • i added the scan_ssid=1 command in the wpa file
    but i cant get it to connect.

the LED light flashes for a minute or two, signaling boot, the the led turns on continously. But i cant get a connection.
i tried putting the zero on the GPIO without reaction
also powering it with the default usb power input of the pi didn't work.

Currentl i can not provied any logs, as i can't connect vie SSH

i am using the Prusaprint.img image provided by prusa here:
https://www.prusa3d.com/download-prusaprint"
flashed on a Sandisk micro SD HC

Does anybody have an idea what i could have done wrong softwarewise or did i buy a fried board?

Thanks,
flo

did you edit the country part in the octopi-wpa-supplicant.txt ?

Hi Weezl,

Thanks for your reply,
Yes i did,
My octopi.wpa-supplicant.txt file looks exactly the same as on my working instance on the rpi 4B.

Have you tried putting the card from the Rpi4 into the Rpi0? Does it connect to your wifi if you do? If not, the chance of something being wrong with the Rpi0 are high.

PS: how sure are you that you have a Raspberry Pi Zero W instead of a plain Zero?

My Chiron (with the RPI4 connected) ic currently running a Print with 20h remaining, so i can tell you more tomorrow.

PS: how sure are you that you have a Raspberry Pi Zero W instead of a plain Zero?

yes its a zero W V1.1