Octopi connects to PI, but does not see printer

What is the problem?

I've had a running Prusa MK3S with a Pi 3B permanently connected, and Octopi working fine with it for a year (also on my second Mk3S). Over the last week the printing stopped "sometimes" - I cannot reproduce it. As of last Monday I could not print at all anymore. To clarify: I see the printer in Octoprint on my Mac, it does connect, but I do NOT see the actual temperatures of the bed and the nozzle. And the "print" and "load" buttons are greyed out.

My apologies if I'm posting in the wrong forum, I've searched for two days to get solutions but can't seem to ask Google the right questions.

What did you already try to solve it?

I verified all the software settings in the Pi, on the Prusa, and in Octoprint (this is the link describing all steps)

I checked the wiring between the Pi and the Einsy board, even replaced them.

Update:
I installed a clean Octoprint version on another Pi, and connected it with the USB cable to the Einsy board. It now runs these versions:
OctoPrint version : 1.8.6
OctoPi version : 1.0.0
This solution works, but it isn't using the RPi connection. So I wired this new Pi to the Einsy. Voila, it works.
Next step: the SD card with the working Octoprint in the original Pi. Also works.

So I'm up and running again (assuming the problem isn't intermittent), and I don't see any differences besides the use of a different SD card.

I may not see the problem for looking at it too long. And I would like to understand what was wrong, please share thoughts on this problem.

Have you tried running in safe mode?

Yes, same result

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Let me know if this does not work:

octoprint-systeminfo-20230125105643.zip (34.4 KB)

Additional information about your setup

OctoPrint version - Version 1.8.6
OctoPi version - 1.0.0
printer - Prusa MK3S
firmware - 3.11.0-4955
browser - Chrome Version 109.0.5414.87 (Official Build) (arm64)
operating system - Mac OS Ventura 13.1 (22C65)

Do you have another program running, like Cura, that likes to fetch the connection to the printer for it's own purpose?

2023-01-23 17:59:28,386 - octoprint.util.comm - INFO - Connecting to port /dev/ttyAMA0, baudrate 115200
2023-01-23 17:59:28,392 - octoprint.server.util.watchdog - INFO - Running initial scan on watched folder...
2023-01-23 17:59:28,392 - octoprint.util.comm - INFO - Failed to connect: Port /dev/ttyAMA0 is busy or does not exist

Thank you Ewald. And I'm not running a program that may fetch the connection, not that I am aware of. I use SuperSlicer and never configured it to talk directly to the printer. The IP address of the Pi is unique when I check that in my router.

Am I overlooking something in your question?

The IP address of the Pi is for communicating from a browser with the OctoPrint server.
To connect to the printer, you need a USB cable.

Yes, or connecting the Pi directly to the RPI pins, which is how this solution is set up. Always worked fine and still works fin on the second Prusa. (And works again on. this Prusa, see my update in the posting).