Octopi does not display the hot-end temperature


#1

I'm new to 3d printing and Octopi so please be gentle. Octopi does not display the the hot end temperature either on the graph or temp display. It does not allow to set it from off to on. The heated print plate will go from off to - when I set a temperature and it does does show up on the graph. I'm using a Creality CR-10s pro. There are a lot of interactions between an external Cura, Optopi and the printer, that I don't understand, like temp settings.
The printer Ver is 1.40.0 and Octopi was just updated about 2 hours ago.
Thanks for any help you might provide.

Arta


#2

Hello @arta,

you may have a look on this thread. OctoPrint can't handle the format handed over from CR-10


#3

I just want to add that it can't handle it because Creality decided to invent their own format and break compatibility in the process :wink:


#4

I saw that on the forum and I was pointed to a fix using a python script in a certain directory, not remembering the directory is a sign of old age 73. But regardless it worked. Now I just need to learn the nuances of Cura 3.6.0, Octopi, Freecad and Creality. Thanks for the help.


#5

I thought I replied but I don't see it. I saw the earlier post a applied the suggested fix and it worked.