Octopi doesn't recognize printers SD Card

Octopi doesn't see the printers SD Card

Why have you deleted the template and filled it in?

With that information you gave, all is just a shot in the dark...

There isn't much info to add. I don't know what to try. Octopi connects to the printer the "Upload to SD card button is disabled" tried taking card out and putting back in didn't help.

Oh yes i did check the setting and SD Card is Enabled

I found a similar post on the forum that i responded to but didn't get a response from ,actually you mentioned that I should keep to my original post which by the way I still don't know how to "close" a post as "solved"

So here i am starting a new post with this

Sorry for the confusion...

What OctoPi version?
What OctoPrint version?
What printer?
How are the settings in OctoPrint? - Is the printer's SD card enabled?

OctoPi Version 0.18 RaspBerry Pi 3 Model B Rev 1.2
OctoPrint V 7.3
Printer TronHooo Ts220s
Yes in the setting the Enable SD Card is enabled

octoprint-systeminfo-20220208151130.zip (710.9 KB)

There is actually coming something from the printer's SD card, but the format is quite unusual for my opinion

| Recv: n:16:m:NodeMceFP.gcode
| Recv: n:17:m:NodeMcuP.gcode
| Recv: n:18:m:CFFFP_calicat.gcode
| Recv: n:19:m:CFFFP_Robin.gcode
| Recv: n:20:m:CFFFP_goodBad.gcode
| Recv: n:21:m:CFFFP_do_it.gcode
| Recv: n:22:m:CFFFP_Doit3mm.gcode
| Recv: n:23:m:CFFFP_AmicaBase.gcode
| Recv: n:24:m:CFFFP_AmicaBase1.gcode
| Recv: file num:24

Those files are being loaded manually into the octoprint from my network

Strange, those filenames came from the printer.

yes your right .. those are on the SD card. In terminal of octoprint if i give the M20 command i do get the list of files on the SD card so how do i get to see them in the "files" list on octoprint??

What exactly does the response to an M20 look like?

Also, please enable serial.log, connect to your printer, produce a system info bundle, upload it here.

Attaching the Terminal output from the M20 + The system Bundle..

octoprint-systeminfo-20220208164209.zip (774.7 KB)
M20_respond.zip (516 Bytes)

Ah. Another case of a printer vendor coding up their own firmware without any resemblance of a standards compliant communication protocol implementation.

The response to M20 is completely and utterly wrong.

It's supposed to something like this:

Begin file list
End file list

What your printer's firmware is producing there is not even remotely standards compliant. Additionally, it also doesn't respond to the attempt to initialize the SD card (M21) with anything but an ok (it should also say something sd card initialized). So, in a nutshell, this printer's firmware is broken in exciting new ways.

I suggest you flash mainline Marlin on that thing (also because frankly, if they fiddled around and broke THIS, who knows what else they broke or what shortcuts they made with regards to safety). Your alternatives are living without sd card support or writing a plugin that translates this nonsense into something usable.

Thanks for your input... Frankly I have an open query with the manufacturer since as you mentioned here I did find other Gcode issues while poking around with the terminal in octiprint. So I wont ( dont know how at this point in any case) flash Marlin but just out of curiosity doesn't the hardware have any influence on the what version of Marlin gets installed??


The answer i got from manufacturer was they are not using open source that I should not change the software!! Still waiting for a list as to what Marlin codes are acceptable !!

Interesting ???

Reason not to buy from this vendor again I'd say as they are shipping faulty products and don't seem interested in fixing their bugs.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.