Octopi - ERROR The requested URL could not be retrieved

What is the problem?

I have 3 seperate octopi running on 3 seperate Raspberry Pi but cannot open neither of the UI interface in the Google Chrome. I used the IP addresses analysed by the IP Scanner for example: http://192.168.1.17/

It used to work but suddenly not anymore and only what I am getting is ERROR: The requested URL could not be retrieved (see printscreen bellow)

What should I do? Thank you

What did you already try to solve it?

Reinstalled the octopi many times via Raspberry Imager

Have you tried running in safe mode?

No. Cannot access the UI

Did running in safe mode solve the problem?

No. Cannot access the UI

Systeminfo Bundle

No. Cannot access the UI

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

CR10 V2, Ender 3, Newest Octoprint 0.18 via Raspberry Pi Imager. Windows 11.

Print screen:

Have you set the hostname(s) to three unique names? Having three "octopi" in the same network often causes havoc with the DHCP server. The hostname is stored in /etc/hostname. You can also change the host name with instructions in this thread.

Once you have set unique names, reboot the DHCP server (probably your router) and the system you are trying to connect with and see if the situation improves.

Hi. It Still does not work unfortunately.

Okay! It was solved. The problem was in the Google Chrome browser i think due to cache so opening up the same address in incognito mode solved it. Thanks!