Octopi: How to use pip through ssh

What is the problem?

I am trying to run a plugin.
The plugin dev suggests installing some packages manually through ssh because the Octoprint plugin manager could time out while compiling.
When I log in to my rasperry pi running Octopi 1.7, pip is not found (using sudo or not).

What did you already try to solve it?

I have searched for this on the internet, and the solutions don't seem to work or be applicable.
I have used apt to update all of my packages.
I have python3.7 installed (although it looks like the default python is version 2).
I have tried "pip3"
It looks like "root" is disabled.

WRITE HERE

I have dug through some scripts and it looks like Octoprint is set up with a virtual environment activated. Do I need to activate the virtual environment in order to use pip? Do I need to activate the virtual environment In order for things I install to be usable by Octoprint?

WRITE HERE

To install into OctoPrint's virtual environment, use the command: ~/oprint/bin/pip install yourpackage from SSH

1 Like

Thank you very much! It worked!

1 Like