OctoPi Image Downdload Keeps Failing?

My OctoPi can no longer self-udate, so I am trying to download the OctoPi image from the site here - OctoPrint.org - Download & Setup OctoPrint I have tried half a dozen times: via VPN; VPN disabled; via Xtreme Download Manager; via Firefox' built-in downloader; via computer running Linux; via computer running Windows... every single time, the download fails. Is there a mirror server from which I can download this?

How does it fail specifically? I can't see any issues.

I don't really know. In Xtreme Download Manager, it will download a percentage of the file (it's never the same amount - usually between 15 and 40%) and suddenly go into pause mode, from which it can't be resumed. With Firefox's built in downloader, it will download a percentage of the file and then just fail. That's all Firefox reports.

Try from a different network if possible. I can't see any issue here, downloads just fine from all mirrors (which the download link already redirects to via a load balancing setup).

Mirrors in rotation are:

BTW: OctoPi does not self update - OctoPrint does.

You may check your internet connectivity and - if you connect to the router via WiFi - the WiFi connectivity and the channel usage.

Yeah... my OctoPI image is so old that OctoPrint refuses to self-update anymore. I finally found a link on here in another post that did complete. I ran the md5 checksum on it just to be sure....

I don't know why I am having trouble with that download, but thanks for trying to help! I appreciate it.