OctoPi in read only -help


#1

What is the problem?
My octo seems to be in read only and has no ssh via ethernet or wifi

What did you already try to solve it?
I have installed Octoprint on an sd (32G) . It boots but it has errors in the boot but it scrolls too fast for me to see what is happening. I tried a few methods but I see the OS system is in READ ONLY so i cannot write the boot to a log.txt
Further , I cannot SSH in so I must use direct key monitor to see anything . The wifi does not work and so I fitted via ethernet port to modem , even though my modem sees the PI via this wired method , I cannot SSH in with Putty or browser ..

I tried to su and use mount but I could not get the password for su ..

I would appreciate how to diagnose this issue as I am not a fluent linux head..
Thanks,,

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Updating my info - I installed the latest firware of octo todays @ date
[OctoPi 0.15.1]


#3

Assuming that you can get a remote shell, a terminal command like cat /var/log/syslog | less might show you what just happened during bootup. Just keep pressing the space bar to see one page at a time or "q" to quit.

Did you follow the instructions for the OctoPi image? Put the country code line above all the other stuff in the configuration file mentioned and make sure that the country code is in UPPERCASE. If that still doesn't work, share your configuration file here for wi-fi.

While you're setting up the wi-fi in that initial step, if you create an empty file in that same boot partition called ssh it should start up that service by default.


#4

Other things- use sudo [command] instead of su, and share the logs of how wifi fails- though that can probably wait until you have ssh working.

Read-only sounds like a corrupted filesystem.


#5

With sudo is there a default password for octoprint ?


#6

If there's a password for pi, use that for sudo.


#7

step A) I logged in and typed after the "pi@octopi:~ $ "prompt :

pi@octopi:~ $ sudo cat /var/log/syslog

I am not sure if "|" symbol was required after syslog but I couldnt get pi to type that symbol even though I found it on my keyboard,it showed ~ instead ...it responded :

" sudo: unable to mkdir /var/lob/sudo/ts: Read-only file system "

Step B) In Gedit in ubuntu , I did edit and placed

country=AU # Australia
in capitals at beginning of octopi-wpa-supplicant.txt file

Step C) In the main directory where supplicant.txt is , a file ssh.txt is empty and exists.

I am still no fix at this stage and still cannot extract or see my boot log details.

Ty for patience


#8

So you're telling me that you think you typed in that... and then Raspbian said "sudo: unable to mkdir /var/lob/sudo/ts: Read-only file system".

This means that you typed in...

sudo mkdir /var/lob/sudo/ts

At least you got the sudo part correct.

Seriously, though, any command that begins with sudo deserves some respect. Before I press the ENTER key I check the command line carefully to make sure that I've not made a mistake.

The pipe symbol is above my return key and it requires me holding the Shift key in order for that to happen. And yet, it wasn't really necessary if you know how to highlight a command and then copy/paste it into your command line there. I think I'd go with that version this time.

cat: Will concatenate (type) the content of something to the screen.
sudo: This "pseudo", this will temporarily turn you into the root (admin) for one command.
less: A filter which will take output and put it to the screen one page at a time. The former command we used to use was called "more" and this is a play on that theme.
/var/log/syslog: The most recent log of the system.


I don't remember suggesting that a .txt extension be on the ssh file. If it has an extension then it won't be recognized and this would be why this service isn't available. I think I would put the microSD back into your workstation and rename it without an extension.


#9

Ty for helping -
Yes that is exactly what I typed and can post a picture of the screen .
I cannot for some reason actuate the pipe symbol even though it is on my keyboard and i use it to code in other circumstances using the same usb keyboard on my ubuntu pc. The symbol when pressing shift is ~ which is normally found above the ` to the left of my digit 1 on keyboard. very unusual ?
Last night I tried using different rasberry pi B+'s and not difference .
The Pi octoprintsd card finds the ethernet yet I cannot connect to it via a browser or ssh .
The octoprint pi does boot into waiting for a user and password which does work but the boot has shown errors that up until now are still out of reach .

I tried both SD 32G and 8 G cards and effectively the same result.

I am going to try a different keyboard if I can locate one which may solve the pipe command observation above.

version octopi is shown on sreen when booting as 0.15.1 so that looks favourable.

I will update once I try a different keyboard but I wonder if selecting AU for wifi has anything to do with arrangement of keyboard keys ? Just thinking outside box..


#10

If I were you, I'd reflash. This sounds like a severely broken file system and you will probably continue to run into issues even if you get it back into rw mode.

Always makes sure to shutdown your Pi before pulling its power, and use SD cards from a reputable brand.


#11

Thanks foosel,
i have reflashed about 7x on various cards and several copies of octoprint . I will post my findings when i complete more tasks . Oddly , I ran from these pi boards a vers 14 octoprint successfuly . since upgrading the 3d i decided to update the octo ..lol .. did i push my luck?


#12

My mission besides getting it working is to simply look at the boot log to find what the "fails" that fly past my screen are ..

Can I stop the boot screen from scrolling automatically ?
Even better, could i get the boot screen sequence to automatically write its log into a txt by editing a file in the sd card prior to putting it into the pi via my ubunut gedit pc ..?


#13

Have you kept using the same SD card throughout all these flashes? If so I'd suggest to swap it for another/a new one. Those things don't hold forever, and filesystem issues that survive reflashs scream card issues.

Even better, could i get the boot screen sequence to automatically write its log into a txt by editing a file in the sd card prior to putting it into the pi via my ubunut gedit pc ..?

Theoretically you can get all these messages by running dmesg, and you could rediret the output of dmesg to some log file on /boot, e.g. dmesg > /boot/dmesg.txt. But if your file system is mounted read-only and remounting it as read-write doesn't work you are out of luck.

The Pi by default uses GB keyboard layout so make sure you use that. It's irrelevant what symbols are printed on your physical keyboard, your keyboard only sends keycodes and your Pi turns them into actual keypresses based on the currently selected layout. Alternatively select whatever layout is your actual physical layout via sudo raspi-config. I think the option was something along the lines of "Locale and Layout" or something. Not 100% sure though and can't check right now.


#14

I have tried several SD cards : 8G and 32G .

I'll try work with dmesg. and see how I go .

How does the Pi know to use the GB keyboard ?


#15

Beautiful. You described the problem and what you're seeing in such a way that I can also see it.

You get these anomalies when the selected keyboard driver is wrong. Out-of-the-box, a lot of Raspberry Pi and Raspbian (the operating system) assumes that you live in England since that's where the Raspberry Pi Foundation is, presumably. For me, if I don't change the keyboard setup to US -> American English then the double quote character can't be typed so that causes some grief. Change the keyboard driver and you should be happier.


#16

There is an issue doing anything because of the nature of rasp pi READ FILE only imposed on the system (for an unkown reason) , it cannot make changes to the keyboard. I will need to do something else ..


#17

UPDATE- I can establish the pi- boards work with a rasbian OS install SD card. So the issue seems to be down to the SD cards or the image loaded into the SD card itself.


#18

UPDATE- I went back to my zip file and RE-unzipped it and reflashed it with the same ETCHER flasher on wind7 machine. I did not make any changes to anything before testing the next phase - Now the pi boots up on ethernet card connection. without file read only errors. Could it be the previous unzip was corrupt or was this process just conincidence... Lets see.


#19

UPDATE- Now that I established some flash and operation on ethernet , next step to modify the wifi file in notepad++.
result -
When changing the details of the setup file as per instructions the system no longer boots with errors different to the original post here. I have purchased new sdcard to see if I am just playing with corrupt cards..


#20

UPDATE- I flashed a ne8G sdcard and changed the setup file and it has booted with ethernet . Last is to get wifi working ..