Octopi issues on Rpi5

What is the problem?

Getting remote control on octoprint

What did you already try to solve it?

I initially struggled to get the octoprint to run on pi but all seems to be working now. I just cant connect it via iphone or laptop.
I tried to look into the octoprint settings to see if I see any settings related to remote control but I didnt see any.

Im trying to type my ip + user name in the laptop and iphone browsers.
I tried that on several browsers.
I tried to disable firewall.
I tried to log in to octopi.local. And tried to add user name at the end here as well.

Have you tried running in safe mode?

No, I dont see how it’s related.

Did running in safe mode solve the problem?

Hello @Uzman !

From the recent OctoPi homepage:

Thanks for your response.

Yeah I saw that, I read on this forum that I should use octoprint deploy instead, and it does work.
I just can’t log in remotely.

You have been taking about OctoPi.

You mean from outside of your home network?

Sorry, I do get confused between octopi and octoprint :sweat_smile:
Im now trying to log in using the same wifi

There are two types of "remote login" with two sets of credentials.

OctoPi (i.e. Operating System) logins usually are SSH unless a desktop has been installed and then Remote Desktop (RDP) or VNC can be used. The username and password for these logins are usually set when the SD card image is created.

OctoPrint logins are browser based. When OctoPrint is started for the first time, a set of credentials are created which are often different that the OS credentials.

Enabling remote logins from outside your local area network is highly discouraged but there are some relatively safe options. I don't believe this topic is discussing these options.

Since you are mentioning iPhone and laptop connections, I assume you are using WiFi. Your WiFi router could be configured to isolate each WiFi device from other WiFi devices. This needs to be changed if enabled.

Please explain what you mean by "disable firewall". Using "octopi.local" assumes there is a Bonjour service running in your local area network.

You shouldn't need to add a username (or password) to the URL you type in the browser. If they are needed, the browser will prompt for them.

What OS are you running on the laptop? I think troubleshooting with the laptop will be easier. Do have (or can you connect) a monitor and keyboard (and mouse) on the RPi 5? If not, then we need to troubleshoot connecting with SSH as well.

Hi, thanks for your response.

Although this topic is not on that, this is what I to get in the end, so i’d be glad if you have any information about that.

I tried to disable the real time protection option on windows security, just to check if its related. I guess its not.

It works on the pi with the pi IP + my account name ( so I tried that and some othet options I mentioned

windows 11, can connect mouse and keyboard to the pi

What OS did you install on the RPi 5? I'll assume "Raspberry Pi OS (64-bit)". With a monitor, keyboard, and mouse attached to the RPi 5, we can get the IP address by opening a terminal window and type ifconfig. On the laptop, open a command window and type ipconfig /all.

What we need is the IP address, the netmask, and the gateway. On the laptop type ping ip.add.of.rpi5 and on the RPi 5 type ping ip.add.of.laptop. Also ping ip.add.of.gateway on both. Are all of these commands successful?

What browser are you using on the laptop? Open it, and type http://ip.add.of.rpi5
and tell us what is the response?

If any of these fail, then we need more information about your WiFi router. Is it a combination modem / router from your ISP? Can you connect to its UI (from the laptop)?

Your IP address is not - this refers to "this device" in networking land. So on your Pi, this refers to the Pi, so it's fine. On your laptop, typing refers to the laptop, which is not where OctoPrint is.

You want the IP of your Pi on your network, normally something like for example.

Since you've set it up with octoprint_deploy, you're right to use the instance name in the URL. Your instance is at /ender3, so you should always access it using this i.e.

You can get the Pi's IP address using the first command @b-morgan posted - ifconfig /all, then use that to try and connect from your laptop.

You got it! I was just using the wrong address.
I really hoped that was the case!

@Charlie_Powell @b-morgan Thank you very much for the help, I appreciate it.

Do you know why octopi.local doesnt work?

octopi.local requires Bonjour services. If you have a DNS server in your local area network (check your DHCP server) then you configure can your LAN to use hostnames (i.e. octopi).