Octopi.local doesn't work on windows laptop


#1

What is the problem?
Newbie here, just set-up Octopi on my CR-10S using my MacBook Air. I'm able to connect to it and the printer using octopi.local on my MacBook but when I try to log on from my Windows laptop or iPad it asks for a username and password. I tried username pi and password raspberry, and also the password I changed it too during the setup but nothing will work. I just keep getting an error message that it's the wrong username or password. I've tried everything I can think of. I simply can't connect with anything other than my MacBook Air. I also tried connecting using just the ip address and get the same log on screen asking for the username and password.

Any Ideas what I can try. Seems to work fine from my MacBook...


#2

Name resolution hacks for Windows for trying to use the hostname to get to it. Note that the fully-qualified hostname is octopi.local and not just "octopi", btw.

From MacBook:

ssh pi@octopi.local # raspberry is the default password
Web interface: http://octopi.local/

During the Setup Wizard, it would be good to know if you turned on User Access and created an account or not. When you say that you changed the password, it's important to know where you tried to change it (during the Setup Wizard's User Access page and what was the username you added?)

I'll assume that you used Access Control since that sounds like how's it's behaving. When you see this login screen again, you'd need to use that same user/password pair you included before. Note that this doesn't change the ssh login's password for the pi user.


#3

@OutsourcedGuru explains it well. The .local address capability is an artifact of Bonjour Networking support which is an apple thing - three work arounds are, I believe, installing itunes on the windows system (which installs enough of bonjour), or address via it's IP address, or google bonjour for windows (it's on the apple net) it will enable enough of Bonjour in your windows box to make it work.


#4

4th option: install Samba on the server. This will let you use http:/:octopi/ on windows (without the .local)