Octopi.local home page not correct

What is the problem?
Hello, I am fairly new to this. But managed to get get things working. But suddenly the home page is not coming up in the standard way. The page is mostly black

What did you already try to solve it?
I can ping the raspberry and can ssh into it.
I've tried looking at the logs but nothing jumps out at me
I started it in safe mode with the same results.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

It seems that suddenly you have installed or enabled TouchUI. If memory serves me right, there's a hamburger menu on the top right which has an option to switch back to the default UI.

I've tried looking at the logs but nothing jumps out at me

Generally speaking, "we'll be the judge of that". We often can't help without seeing the logs.

It frankly drives me up the wall when people withhold logs because "nothing jumped out at them". They usually don't even know what to look for, don't know that the order that even harmless looking lines in there might already be an indicator, don't understand that all the stuff logged at the start gives absolutely necessary information about the runtime environment, and that an error doesn't necessarily manifest with huge stack traces and bright flashing colors but that more often than not it will be a minuscule detail hidden in a simple info or warning line.

The logs are requested for a reason. Share them. Don't withhold them. You are only frustrating people who would love to help you and are sabotaging your own attempt at getting help with an issue you are facing. I honestly can't comprehend why someone would do that instead of just sharing one or two bloody text files.


1 Like