Octopi.local will not accept password

What is the problem?

I set up Octoprint on a Raspberry Pi 4. No problems. Changed the password from raspberry and I was able to see the web site on a browser on several other computers using the password I set up Octoprint with and still using pi as the sign in. I printed something uneventfully to test things.

Suddenly I can't access the server from the web interface. I get "Incorrect username or password."
I changed the password using raspi-config and again was able to get the server to start. But again using the web interface with the new password no luck. I also used WinStp to get into the server with the same password without issue.
I am using Firefox and I also tried Vivaldi to log in. I assume that the password and log in to access the server is the same as what is used to start Octoprint.
I did not try safe mode.
Latest version of Octoprint 1.6.1 and OctoPi 0.18. Win 11 preview version. Octoprint worked on it previously.
Without getting onto the web interface I am not sure how to get the System Information Dialog.
It seems that the password or login name somehow is different than the corresponding ones used to start the server.
I tested Octoprint on a Prusa 3ks.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


I think you're mixing up the password for Octoprint and the OS (raspbian (rapberry pi os)).
You need the Octoprint password to login via webinterface and the OS password to login via ssh or command line.

If you want to change your webinterface password you can use this tool GitHub - kantlivelong/OctoPi-SystemMenu: Simple TUI for common tasks on OctoPi.
Just login via ssh (username pi and the password you set via raspi-config) and run

bash <(curl -s -L https://github.com/kantlivelong/OctoPi-SystemMenu/raw/master/src/menu.sh)