Octopi.local works on ssh but not in broswer

What is the problem?
Cannot access octopi via hostname (octopi.local) on Windows in any browser (Firefox, Chrome, Edge) or via pinging, but CAN access octopi.local via ssh (in putty or Cygwin, but not command line due to timeout). IP address works in all cases.

What did you already try to solve it?
Installed bonjour, samba, tried octopi.local:5000

Logs (syslog, dmesg, ... no logs, no support)
Unsure what logs are necessary: can see hostname (octopi) via Fing, but pinging octopi.local results in an incorrect ip address (some ip belonging to century link)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Connect to octopi (on Pi 3B+) from a Windows 10 machine

Found your problem.

Um... go to your router's DHCP settings, issue a static IP address high up in the range (.200 to .240, say). Then do an Administrator -> command shell in Windows and add a C:\Windows\System32\Drivers\etc\hosts file entry which looks something like:     octopi     octopi.local

Then run an nbtstat -R to reload that and a ping octopi.local to see if that works.

1 Like

I was trying to avoid a static IP (I don't have control of the router - this is at work). If I put the current IP in the hosts file, it does work, but I was hoping for a more general case. I understand if this is not possible with Windows.

Found some new information. My computer is currently connected to a wifi extender, and for some reason unknown to me, it only works if I connect with a static IP address. Anyway, in that configuration, I usually specify a default DNS. With all this the internet works great.

However, it turns out that specifying that DNS causes octopi.local to redirect to some weird address not even on the network. If I don't specify a default DNS (in Wifi -> IPv4 properties -> use the following DNS server settings), octopi.local works (yay!) but the internet no longer works (can't resolve IP at google.com or wherever).

Does anybody have any idea why this would be or how to fix it? Thank you.

Contact your network administrator. They will likely know why. And you should contact them before adding any device to their network let alone adding a static IP address to it.