OctoPi no longer accessible over wlan0, still works over eth0

What is the problem?
OctoPi device and everything on it is accessible over eth0, but nothing, not the webserver, not ssh, not ping, works over wlan0, however wlan0 did work with no problems up until around a week ago.

What did you already try to solve it?
I have tried looking into DNS issues (unlikely, but did just remove a Pi Hole from the network, see below), DHCP issues, checked ifconfig to see if the Pi disagrees with the router, checked what addresses the router believes has been given to the Pi, and tried pinging the pi over it's eth0 address and wlan0 address. I also idiot checked myself by checking the octoprint-wpa-suplicant.txt file (or whatever it's called) on the SD card to be sure that the login credentials were correct, and they still were, but I have not changed those since long before the Pi was working so I do not believe this is the source of the issue, unless there is more complexity to this that I do not understand.

The Pi used to work over Wi-Fi and did for a really long time, but now doesn't. When it's connected over Wi-Fi, the Orbi router page says it's at, which is the static IP address I set it to in the router's DHCP settings. However, it does not respond to pings, can't be SSHd into, and the related web GUI is also inaccessible. When I plug it in over ethernet, it gets assigned a different IP address,, which I can then use to fully interact with the Pi. From here, I sshed in and ran ifconfig, which shows that eth0 has and wlan0 has, so the issue with Wi-Fi is not the issue I've had in the past when setting a static IP where the pi doesn't notice that the router has a different IP address set for it, and then it becomes inaccessible until it checks DHCP again.

What is really confusing me with my somewhat cursory understanding of how Linux networking, and networking more broadly works is that while the device is plugged in over ethernet, I can now access the Pi via, which is the wlan0 (aka Wi-Fi if I understand correctly) IP address, which didn't work just a moment ago! This is totally repeatable, I pinged, let it respond a few times, then unplugged ethernet, the device stopped responding, then I plugged ethernet in again, and it started up again! I don't know if this is actually the cause, or even related to the issue of the Pi not being accessable from, but it seems unusual and I don't understand why it happens, so I thought I would include it here. There are probably many ways I misunderstand how all of this works, but I would love it if someone could point these out so I can learn from this, and be able to diagnose what is actually wrong with my Pi at a later date.

Logs (syslog, dmesg, ... no logs, no support)
dmsg: https://pastebin.com/Q0PSKm4X
syslog: https://pastebin.com/pv4CNXw2
octoprint.log: https://pastebin.com/T45EE9zt
haproxy.log: https://pastebin.com/np0hqKwv

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Currently, my Orbi routers are set up with one satellite to supply the static IP address to the Pi. I am trying to connect from a windows desktop on ethernet and an android phone on wifi (phone via OctoRemote app. The pi running octopi is a 3b+ v1.2 and I am using some canakit USB wifi dongle from a random Pi kit I got a few years ago.

As far as LAN changes since it had worked properly, I removed a Pi Hole that was configured as both the DNS and DHCP servers for my LAN. This was done multiple days ago, so everything should have had time to refresh. I don't see how changing DNS would have any impact on this in particular, as there is no name resolution in pinging an IP. Based on dhclient -d -nw, it also appears that the Pi is aware of the correct DHCP servers, pinging and getting for wlan0 and (new IP) for eth0, basically what I expected. For context, the Pi Hole was at, and the Pi seems to have forgotten about that just as it should have, so although the Octopi Pi stopped working over Wi-Fi around the same time as the Pi Hole was removed, I cannot see how it is causing the issue.

Please help me figure out why the Pi is not accessible over Wi-Fi, and if possible, help me understand what is happening with the whole eth0 connection effecting the wlan0 connection thing. If another log file is needed or just any other information, please let me know and I'll gladly provide it. Thanks in advance!

I had a similar experience on a Pi 3B+ where it was working one minute and did a reboot and quit working on the wifi but would on hardwire. In my case, I found the SD card had gotten corrupted. Used a backup card and it has been working perfectly since.
Might give that a try.