Octopi no longer working/connecting, the website isn't up?

What is the problem?
Octopi is connected to my router and 'wifi' but I can't connect to octopi anymore. The website doesn't work and the app doesn't work and ssh doesn't work.

What did you already try to solve it?
I checked the SD card to see if the internet info was correct, and it was.

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Using a bell home hub 4000 as my router. No problems in the past, just now it doesn't work.

Did you check the connected devices list on your router?
Maybe the ip address of the pi has changed.

It did change, however I was unable to SSH or go to octopi.local, which is what I use since I have bonjour I believe.

I double checked my router and octopi was gone. So it only connected momentarily.

I'm just confused what to do. My octoprint has been running steady for a year now. I recently updated to Python 3 to try new plugins. I installed a GPIO RGB plugin because I wanted to run some RGB led lights.

It was fine for so long but then all of a sudden it just isn't turning on or connecting.

You may connect the Pi to a HDMI monitor/TV.

At the end of the startup sequence, you get the actual IP address of the Pi.

I didn't even think of that. Got super flustered with it not starting.

So I did connect it and this is what I am getting.

It didn't auto login and afterwards said to visit that URL for octopi, however when I type it into my browser, I get the same issue as before.

No idea what to do.

The raspberry pi is unable to ping (google). Unless I did it wrong. I think I am going to try and figure out if its properly connected or not.
Screenshot 2021-07-14 033223

So the wifi is setup correctly. I did check this earlier by removing the SD card. The name and password are both correct. No idea why it would connect and then disconnect immediately? Maybe my wifi on board is damaged? :frowning:

Have you tried an Ethernet cable?
Be aware that the Ethernet connection will have a different IP address

Ethernet worked, so it means its not an octopi problem?

In the little time I got ethernet to work (since its not feasible to have it plugged in all the time for me), I disabled GPIO RGB plugin. Since that was the last change I made.

Then I ran sudo raspi-config and re-did auto login as well as enter the wifi information. No idea if octoprint overwrites that or not.

So far its working, I can access the webpage and ping google. Super glad, hope it stays that way and isn't temporary.

1 Like

Setup octoprint back with my 3D printer and it has connected. Will update here if things go wrong, fingers crossed they don't :crossed_fingers:.

There's still a large chance that GPIO RGB plugin was the issue, but no sure fire way of knowing.

1 Like

So I turned GPIO back on and it crashed my server again. The plugin OctoPrint-GpioRgbController is dysfunctional unfortunately.

For the sake of others who may run into this issue as I recently did, verify that both the red and the green LEDs are illuminated on your RPi. The red LED illuminates when the RPi's 5.0V power is present. The green LED illuminates when the RPi's 3.3V power is present. The 3.3V power runs the networking circuits. So, if the 3.3V power is dead so are your network circuits.

1 Like

Sorry forgot to update here. There's a very high chance I shorted my GPIO pin, but the latest update of that plugin now works really well. It didn't crash my server and was able to change the pins and get it working with my RGB strip.

I think the plugin had an issue with a dependency and me trying to use it on a small LED using the 3v3 might have caused issues.

I highly recommend people properly ground when playing with GPIO pins with resistors, which I didn't do and give the new update of the plugin a try.

Edit: I got lucky and my raspberry pi recovered I guess. But that is good to know, the green light wasn't on any time it crashed.