Octopi not accessible from phone

#1

Using a Pi3 B+, Octopi SD image installed then updated to newest. Connected to Wifi, single AP in the house, single network.

Currently, using the IP I can connect to both SSH and web interface on any desktop or laptop in the house, connected to either wifi or ethernet LAN. Works fine. I cannot connect to SSH or web interface using any Android smartphone connected to the wifi. I could try to VPN-in to the LAN from mobile data, but I feel like the result would be the same. I continually get either "host unreachable" and "ERR_ADDRESS_UNREACHABLE" when trying to access SSH and the web interface, respectively. Again, same wifi network, the only difference is that it's an Android phone rather than a PuTTY connection or Chrome on Windows.

I cannot find anything, anywhere, relating to the problem I'm having. Does anyone else have an idea?

#2

What's your pi's IP address? What IP do you have on your phone?

I have zero problems connecting from my Android phone to my Pis.

#3

192.168.1.108, and the phone I'm using at the moment (Galaxy S9) is 192.168.1.236.

My brother's is .97, and also will not connect. He's only tried the web interface, I've tried SSH (JuiceSSH) and web interface.

#4

okay, that's just weird. you are obviously both on the same network.

you're using Chrome? Not on a VPN? Make sure 'data saver' is off in Chrome's settings, also try Incognito mode. Of course that wouldn't explain the ssh problems..

I assume your desktops/laptops have similar IP addresses.

Try going down this search rabbit-hole and see if anything makes sense.

#5

Chrome AND Samsung's default "Internet" app. Regular mode, desktop mode, have NOT tried Incognito yet (will try tomorrow)

Primary desktop is 192.168.1.37, secondary is 192.168.1.22, laptop is 192.168.1.40.

I'll link my brother here so he can get more into detail with it, since I was just trying to get it running right for him while he was at work. I'll also take the opportunity tomorrow to try out SSH and web interface from a CentOS server I've got setup on the LAN and see if that functions like the rest of the non-phones.

#6

[From the brother, presumably] Further information that we've gathered so far:

  • I can't access the Pi from either my android phone or desktop (Win10), using any browser, both connected to the same router via the same method (5GHz wireless).

  • I CAN connect to the Pi from my android phone while connected via VPN, regardless of whether I am connected to the home network or out and about.

#8

Stumbled upon this post, and found I have the EXACT same problem. Just got my Ender 3 a few days ago, installed octoprint on my raspberry pi 3 yesterday. Two windows 10 desktops in my home connect to my Octopi via ip address in chrome no problem. My Android phone however, gives the same error that you have. HOWEVER, when I VPN to my router, whether on my home network or away, I can access the octopi from my phone no problem. Which makes no sense at all to me.

#9

"...when I VPN to my router..."

(Meaning) you're not actually inside your private network before you VPN'd in. In other words, you were either using your cellular data and therefore outside of your private network or you were connected, say, to a 5GHz zone which doesn't forward traffic or broadcasts or is improperly-configured.

#10

This happens when connected to my home network, with cell data off, whether I am connected to the 2.4 GHz or 5 GHz. Also, any of the myriad of other devices I have in my home which require I be on my home network to function (remote desktop, fire TV remote, etc) all work from my Android device. Octoprint is the only item that behaves in this manner.

#11

...by using the IP address (IPv4/IPv6) or the hostname?