Octopi not connecting to new Google Wifi

What is the problem?
I recently upgrade our routers from the Apple Airport Extreme to the Google Wifi Mesh Routers. The changed the name of the network to a different name and the RaspberryPi's wouldn't work.

What did you already try to solve it?
I amended the SSID and password in the config file and confirmed the correct country as well.

I still cannot see the RaspberryPi in my device list to be able to config. What could be the problem?

Logs (syslog, dmesg, ...)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

  • The SSID as issued shouldn't have spaces in it.
  • The Apple-based solution earlier fully supports the Bonjour name resolution service. It's hard to say if the Google solution also repeats this broadcast information on all segments of the network.
  • The LEDs on the Raspberry Pi can tell you if it's linked in to the wi-fi network, by the way.
  • Hopefully the Google setup doesn't include hidden zones.
  • Try connecting an Ethernet cable to the Pi to assist in your troubleshooting. Then you can run an ifconfig command to confirm that the wifi device is missing the RUNNING flag which would mean that it hasn't been issued an IP address by your DHCP server.