Octopi not connecting to wifi (xfinity)

What is the problem?
I have followed the steps of flashing octopi to an sd card for my raspberri pi. I setup the ssid and password in the supplicant file. When I plug in my rasberry pi, the device doesn't show up in my list of connected devices. I don't think it is connected to my wifi.

  • Note: I'm not very experienced with network setup, I might be making a simple mistake. I am super thankful for anyone willing to help.
    What did you already try to solve it?
    -I double checked my ssid and password in the supplicant file. I have restarted the pi and my router.
    Logs (syslog, dmesg, ... no logs, no support)
    I have tried following the directions on how to get logs. I don't think I am understanding the steps correctly. I cant access octopi, because it is not connected to my network, so I cannot get the ip address. For using the WinSCP, I don't know what the host name would be. I am happy to get the logs if somebody can help me with this.
    Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
    I am trying to connect to the router that came with my xfinity account. I am trying to connect from my raspberry pi 3 b. I flashed the sd card with octpoprint from my windows pc.

I guess xfinity is an ISP?

Post a picture of your octopi-wpa-supplicant.txt file and black out your ssid and password. Maybe the is a formating error or something similar.

Thanks PrintedWeezl,

Xfinity is my ISP. Here is the picture you asked for.

Do you have the chance to connect a HDMI TV/monitor to the Pi?

If there is a proper WiFi connection, at the end of the startup sequence you should get the current IP address of the Pi.

I’ll give that a shot and let you know.

1 Like

Here is what I got when I tried connecting to a monitor.

The pi crashes while booting.

Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00

could mean there is something wrong with the file system but it could also be caused by other things.

Did you overclock the pi?
Is the power supply sufficient?

Oh and I just tested another thing - did you format the sd card (after you flashed the image) when windows asked you to?

It gave me an other error while booting, but it looks similar and it stopped at exactly the same point.

1 Like

I haven’t overclocked the pi. The plug I have outputs 5v.

I didn’t format the sd card. Should I try a different sd card altogether?

and how many Amps?

yeah go for it if you got a spare one. just to rule out problems with the old card.
If you don't have another card try to flash the image again.

It’s 2.5 amps.

Well I’m happy to say that it was the SD card. Thanks for the help everyone. I really appreciate it.