Octopi not loading after the last upgrade

What is the problem?

After the upgrade to the latest version web GUI is not loading anymore.

What did you already try to solve it?

ps -ef | grep -i octoprint | grep -i python
does not return anything.
rebooting the pi also didn't work
restart in safe mode also cannot boot the GUI...

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Traceback (most recent call last):
File "", line 1, in
ImportError: cannot import name get_versions

OctoPrint version : unknown
OctoPi version : 0.15.1

octoprint.log (81.0 KB)

Hi @toto99303

The OctoPrint version is 1.3.10:
2019-05-28 23:49:36,759 - octoprint.startup - INFO - Starting OctoPrint 1.3.10
How do you usually connect to OctoPrint?
WiFi or LAN?
IP address of via octopi?

It's connected wired, no wifi.
The ip address is reserved in DHCP, it's always the same.

Same for me. Connected oved Wi-Fi.

And you got the log via ssh?

Yes, SSH working fine.

So you get no reaction at all from OctoPrint on the browser screen?

It opens the fail page, attaching screenshot

What can I do to troubleshoot why the service is not running? Can anyone suggest troubleshooting steps? I tried everything described :confused:

@Ewald_Ikemann
I'm starting to give up, I reinstalled manually octoprint via console, did upgrade/update all packages, updated pip to the latest version and no go. Octoprint is not running. When I login via SSH it says OctoPrint version : unknown

Restarting the service does nothing. Also it stopped writing to octoprint.log for some reason, latest logs are before the upgrade I guess...

Sorry for my delay.
It seems it's to a point where a complete new image installation is recommended.

I'm having this exact same issue after upgrade with the exact same results as the OP.

calling ps -ef | grep -i octoprint | grep -i python results in no response

calling ~/.octoprint/logs/octoprint.log results in:

-bash: /home/pi/.octoprint/logs/octoprint.log: Permission denied

calling sudo service octoprint restart appears to do nothing or is doing something in the background but prompt comes right back.

Any attempt to connect to octoprint results in:

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log , there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart .

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Mailinglist or in the OctoPrint G+ Community. Please provide your OctoPi and OctoPrint versions, your octoprint.log (in form of a pastebin link) and explain what you already tried and observed as detailed as possible.

I just reimaged... i couldn't fix it.

I resolved this by rolling back to 1.3.10. Version 1.3.11 works fine on my Geeetech (OctoPi 0.15.0) but not my FLSun. The FLSun is running a MKS Gen 1.0 controller with Marlin 1.1.4. The Pi is a version 3 model B. OctoPi version is 0.14.0.

The rollback command I used is:

  1. ~/oprint/bin/pip install https://github.com/foosel/OctoPrint/archive/1.3.10.zip
  2. sudo service octoprint restart

Thanks.

 - Alex O.