OctoPi not seeing Printer. Not even seeing Serial Port. Worked fine for a year and issue started this morning

What is the problem?

Out of the blue today, Octopi isn't seeing my Printer anymore. The only option under Serial Port is Auto. I get the error "2021-12-30 19:20:04,805 - octoprint.util.comm - INFO - Serial detection: Performing autodetection with 0 port/baudrate candidates. Also, when the USB was plugged in before, and the printer was powered off, the printer's screen would remain on. Now it no longer remains on. Not sure if that helps. Also I did notice a loud fan when I powered the device on this morning, but it worked fine until I paused a print directly on the printer screen (Not in the Octopi interface) shortly after that is when it stopped working. The camera still works, and continues to work when plugged into the port that the printer was plugged into.

What did you already try to solve it?

I've tried two different cables. One that has worked for a year in this connection, and another that I'm sure isn't just a charging cable because I use it to hook up a speaker phone to my computer. I tried safe mode, I even tried opening up the CR10S5 to see if the USB connector was loose. It doesn't seem to be. I really don't know what to do next. I've rebooted the Pi, and the printer multiple times. I wasn't sure if I'd need to reboot after switching the printer to a different USB port on the pi, so I rebooted after every time I did that.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)octoprint-systeminfo-20211230192747.zip (285.4 KB)


Additional information about your setup

OctoPrint version, OctoPi version, Octo, firmware, browser, operating system, ... as much data as possible
OctoPrint Version 1.7.2
OctoPi Version 0.18.0
CR10S5 with EZABL and TH3D unified firmware.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.