OctoPi/OctoPrint streamer is not working with Vega webcam


#1

I am using a Vega USB 2.0 webcam on Raspberry Pi 3 running OctoPi 0.15. The webcam works, but "Webcam stream not loaded" message always shows up in Control window. In Webcam & Timelapse settings, the webcam streaming test doesn't work. But under Timelapse Recordings, I can get a clear snapshot from the webcam when I press 'Test', also the 'Path to FFMPEG' test is successful.

I've uncommented the line camera="auto" and tried different camera_usb_options parameters in /boot/octopi.txt. The Vega USB 2.0 webcam is reported to be working with Octopi (https://github.com/foosel/OctoPrint/wiki/Webcams-known-to-work, https://elinux.org/RPi_USB_Webcams).

What else should I try to get the streamer working? Do I need to modify any webcam or streamer parameters in 'webcamd' or 'config.yaml'?


#2

I followed these instructions here, and it works perfectly. I also had to use the IP of the RPi in settings instead of 127.0.0.1, as it basically just has the js client grab the stream.


#3

I had a similar problem where my camera was detected but my webcam stream would not load. The odd thing I found was that the timelapse feed worked, which told I am using remot3.it for remote access to my printer and the haproxy settings were preventing the camera stream from loading. Octopi did not seem to have access to the local IP or the LAN connection linking the pi to the Internet.

After some thorough digging I found in the haproxy config file the camera backend settings which pointed me to a working IP. In Octoprint settings -> Webcam and timelapse I use the following IP for streaming and now my webcam stream feed works again:

/webcam/?action=stream

I believe this should work for any instance that is run through haproxy, though I could not find any clues online. I hope this helps!