OctoPi on Banana Pi Redux


#1

It seems that people have been successful with octopi on a banana pi in the past however I seem unable to reproduce these results.

I have tried the most recent nightly build of octopi for banana pi. I have also tried building my own octopi using the bananapi–M1 very end. As well as following through Foosels instructions for installing octal print on Raspian on a raspberry pi with the most recent raspian install for banana pi.

There are different results with each of these attempts but the end result is that the server will not run. It does not appear that the server is attempting to start with the octopi for bpi image (either way I get it, downloading the image or creating my own) and I get an error suggesting a package is missing when I follow Foosels instructions for the rpi.

There are some teaser bits of information that suggest the problem could be in pyserial, but I’m out of my depth in digging further right now.

Anyone have some suggestions?


#2

It might be good to focus on the actual error messages, as seen.

For my (software development) students, I make them go into Google and type in exactly the error message. You'd be surprised at how effective this is for taking you to, say, a Stackoverflow page in which someone is interpreting the error message.

In the /boot folder of a standard Debian/Raspbian install, it contains overlays for getting the operating system going. The people who make the Banana series suggest that it's compatible with Raspbian so I personally would go the route where I start by loading Raspbian straight onto the Banana and try to get it to boot with a display/keyboard/mouse installed. I'd then verify that an Ethernet cable, if inserted, would result in a loaded network driver. Next would be the wi-fi setup.

At each step of the way if something didn't work as expected, I'd troubleshoot, find the necessary driver and move to the next step of functionality I was looking for.

Finally, with a working platform, I'd stop, make a backup of the image and save that for a rainy day. I'd then but the microSD back in and go for an OctoPrint install, using Foosel's instructions rather than attempting to apply OctoPi on top of this. Feel free to review the work Guy has done on his repository, though.