Octopi on RPi B+ can see printer port, but can't connect

What is the problem?

Fresh image of Octopi 1.8.6 on a Raspberry Pi B+, expanded filesystem. Can connect with browser to OctoPrint, serial port for printer is detected, but cannot connect. Printer connection verified with lsusb -v.

What did you already try to solve it?

  • Tried swapping connecting cables.
  • Tried setting BAUDRATE to Auto, and then to each specified rate in the drop down menu.
  • Tried adding 500000 and 1000000 baud rates under Serial Connections, tried connecting with them (baud rate of 1000000 was autodetected from firmware using Repetier Server and connects with my laptop, but this does not work with OctoPrint).
  • Tried safe mode
  • Tried removing all peripherals from RPi (HDMI monitor, USB keyboard & mouse). I'm not running a webcam.
  • Tried unchecking "Request exclusive access to the serial port" under Serial Connection Settings.
  • Tried checking Always for "Apply parity double open workaround" under Serial Connection Settings.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20221029140224.zip (229.1 KB)

Additional information about your setup

OctoPrint 1.8.6, OctoPi 0.18.0, Enjoy 3D (https://www.86duino.com/?page_id=11733)
Output of M115 (Firmware query):
FIRMWARE_NAME:86Duino_Print3D_Firmware_1.2.1 FIRMWARE_URL:GitHub - roboard/Print3D: 86Duino 3D Printer Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:86Duino_Enjoy

Hello @Thunder_Chicken !

BTW: What did you say, what printer?
Enjoy3D just shows a gateway site and the link does not work.

And please: Do not delete the template. Please share the systeminfo bundle.

Here is the systeminfo bundle:
octoprint-systeminfo-20221029140224.zip (229.1 KB)

This is the proper link to the Enjoy 3D printer. It's a cheap little printer from Taiwan and there isn't much technical information on their website. It works well enough.

I did some Googling and found that I should be able to get the firmware information by sending M115 to the printer. I'll have to hook up my laptop to it to do that, I'll post that shortly.

I've updated the original post using the template and have provided the firmware information and systeminfo bundle.

The printer connects straightaway when I hook it up to my laptop with Repetier-Server.

FYI The auto-selected baud rate from Repetier Server is 1000000, which does not appear to be an option in OctoPrint.

EDIT: I found where I can enter additional baud rates under Serial Connections, entered 500000 and 1000000, tried connecting with both, no luck.

Maybe it needs some kind of special handshake.
The website mentions a customized version of Repetier-Host.
Bildschirmfoto vom 2022-10-29 16-19-22

Are there any serial logs or terminal outputs in Repetier-Host?

That customized version of Repetier-Host is only available for Windows.

I have been using standard versions of Repetier-Host and -Server on my Linux laptop and have connected and used this printer without problem. I don't have any server logs from Repetier-Host but can try to get them next time I hook up my laptop to the printer.

The printer is in my workshop and the dream is that I don't need to lug my laptop out to the shop to run the printer.

ah kk
sill - any logs or terminal outputs?

just checked the the source code of the firmware on github
looks like 115200 should be the right baudrate.
Bildschirmfoto vom 2022-10-29 16-45-21

I tried all of the default baud rates including 115200, no connection.

On Repetier-Server on my laptop it autodetected and connected at 1000000.

I added 500000 and 1000000 baud rates to OctoPrint and tried both, no connection.

I may have sorted it out. It seems the timeouts were too tight.

Under Serial Connections / Advanced Options, I increased the "Initial baudrate detection pause" time from 1s to 10s. Now it connects at an auto-selected baud rate of 1000000. Will see if I can print something.

EDIT: It's heating up and running prints. Looks like this was the fix.

1 Like

Actually, it seems that it only is a fix while running in Safe Mode. I'm not sure why.

EDIT: Actually, it may not be due to Safe Mode. It won't connect if I manually specify 1000000 as a baud rate, but if I set it to AUTO and let it connect automatically at 1000000. Checking to see if this is the case in Normal Mode...

OK, now I think it is sorted out.

It will start in Normal Mode if I set Baudrate to AUTO with the "initial baud rate detection pause" (under Serial Connection/Intervals & Timeouts/Advanced Options) increased from 1s to 10s.

It will NOT start in Safe or Normal Mode if I set the Baudrate manually to the autodetected value of 1000000. It seems that even at the correct baud rate it still needs more of a pause? I don't know if there is another timeout setting that might fix this behavior without autodetect, but it seems to work now.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.