OctoPi on Zero W2 does not connect to MP Minidelta V2

What is the problem?

I'm trying to have a newly installed OctoPrint instance on RPI Zero 2 W (I've been using an RPI 4 so far and it worked), to connect with my MP Minidelta V2. However when trying to connect, I continue to get timeouts.

No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

What did you already try to solve it?

  • installed Malyan Connection Fix
  • used 3-4 different cables
  • I reinstalled with a 32-bit buster image
  • I tried installing an updated version of CH341 drivers (How to Install CH340 Drivers - SparkFun Learn)
  • I checked with cu if there's some message from the printer (there are: "start" "echo PowerUp" "Marlin 1.1.5" some other initial printer diagnostic and then starts sending temperature)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20231112173804.zip (63.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version: 1.8.6
Octopi version: 0.18.0 (installed from image octopi-0.18.0-1.8.6-20221018093204.zip)
Printer: Monoprice MInidelta V2
Firmware: 1.1.5 (Motor), (LCD) 1.4.2
Port: ttyUSB0 (activated also ttyAMA0 and ttyS0 but useless)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.