OctoPi Out of space?

What is the problem?
Ocotpi will not start

What did you already try to solve it?

  • restarted service
  • rebooted Octopi
  • physically powered cycled Pi
  • swapped Power supply with another known good one.
  • ssh into Pi and ran the command to check that it was running - it did not show that it was.
  • sudo and restart octoprint. IT did not restart
  • from SSH I tried navigating to the Octoprint directory, it showed up, but I was not able to change to that Dir. I tried using Python to manually create the directory and the message "not enough space" was returned.

Hard rebooted Pi again - and this time it came up... as in I'm in Octoprint and it would appear I could use it if I wanted to.
Now having said that, I was getting errors with regard to "Timelapse failing". This occurred after I made some changed to my Timelapse setting, so I revered them back to the defaults. BUt problems seem to persist, and I had an issue where it wasn't working on the last print. So, I had wondered if whatever temp space used for storing before processing was full. and THAT... may be related to the initial problem this morning.

Now that got Octoprint running, I noticed 3 unrendered timelaspes. When I tried to render the 2nd one, it "Failed with return code 1"
More info displays a lot of text from a log I suppose, that at the end says "Conversion failed!"

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)
Octoprint V 1.8.6
OctoPi V 1.0.0 Raspberry Pi 3 Model B Rev 1.2
Creality Ender 5. stock except for Creality metal extruder and glass bed.
Firmware / Ender -5S
64Gb MicroSD card.
My camera is a Logitech C270 connected via USB of course.

Hello @S_J !

How do you indicate that?

Is the green LED blinking after powering the Pi on?

So it starts. Then that is not the problem.

Anyhow, it comes out that this is not an electronics issue: I'll move the thread.

For further investigation, please attach the systeminfo bundle to your next post.

octoprint-systeminfo-20230304132136.zip (19.4 KB)

You have some issues with the homeassistent plugin.

You may check the connection parameters.
You also can try with reinstalling that plugin.

BTW: As long OctoPrint runs properly, always use the Shutdown feature. Hard reset can corrupt the file structure of the Pi's SD card.

Thank you for the reply. Home Assistant? Something I only recently started looking at, I actually don't do much with it at the moment. Adding it to OctoPi was just to give me another entity to have for HA to access, in fact the Pi its on isn't powered up at the moment. I'll uninstall that one since it's not something I'm concerned with right now.

Thanks again.

1 Like

It said it was out of space. Ssh in and do df -h
It will show that there is minimal space in /
The timelapses don't get deleted after you are done. They take up a LOT of space. You need to download the finished ones to your PC and delete them off the pi.

Thanks, yes my Linux cmd line isn't quite up to snuff, but i can manage... will have a stab at that shortly, I suspected something like that, just wants sure how to go about it.

I'm really digging this Octopi, breathing new life into my printer :slight_smile:

Well it shows /dev/root is 99% full. I can't seem to locate that directory. /dev is fine, but /dev/root doesn't show up.

/dev/root is mounted as / which is basically the whole card. Login with ssh and cd .octoprint
Make sure to add the . As it's a hidden directory
Then do du -sh *
You will probably see the timelapse folder is large. Those will be the finished timelapse, and timelapse/temp will have all the raw data. Go into each of those and you can delete files with rm filename to clean them up. Once they are cleaned out, then reboot
To save them to your PC, install winscp and go to those folders first and copy the files, then delete them after.

A little bit of brushing up on some linux command line and I seem to be back in business. I've set up the Dropbox integration to take care of the time lapse files afterwards. Just started my first print since doing that; we'll see how that gets on.

Thank you :+1: :+1:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.