Octopi Randomly Crashes?

What is the problem?

I'm trying to print an Eiffel Tower on my Ender 3v2 and the last 3 attempts Octoprint crashes/freezes/ does something and the printer is no longer responsive, yet the bed and hot end are still on. I cannot access octoprint via SSH or on the web unless I unplug/replug the octopi.

What did you already try to solve it?

I disabled a couple of plugins, (I don't really have that many)made sure everything was updated. I haven't tried SAFE mode yet. I'm attempting to print again, this time disabling spaghetti detective.

Complete Logs

octoprint.log (231.8 KB) plugin_octolapse.log (8.9 KB) plugin_pluginmanager_console.log (328 Bytes) serial.log (22.6 KB)


Here are a couple of timelapses that show's it is stopping randomly (using the same gcode). I only enabled serial logging the last attempt.

Additional information about your setup

Raspbery Pi, Ender 3 v2.



I see some weird hieroglyphs in your octoprint.log but I'm not sure if they were written into the file because of a crashing pi or because you unplugged it.

Does that happen only if you print this gcode or also with other prints?

Another thing I noticed - the filenames on your sdcard don't look right. Are the chinese characters or something in the foldernames?
I don't think that they are related to your problem but I would change them to english names.

Thank you. I have no idea about the hieroglyphs? This seems to only be happening with this particular print. The first time it crashed, I hadn't installed octolapse yet. So I printed 3 pieces for a camera holder successfully, then I installed octolapse.

I don't think I noticed any Chinese characters in my SD card. It's a new Ender 3 v2 that came from China so there's that?

It's been printing that same GCODE for about 9 hours. It hasn't gotten as far as the last print, but farther than the first two failures. If it fails again, I'll post the log files and try a different model...

Thanks again!


Just Safe Mode it and try again. You can finish your print job and then troubleshoot later what's going on.

Thank you for the suggestions everyone. After the failure last night, I changed two things. I disabled the Spaghetti Detective plugin, and I plugged in the Raspberry Pi's power supply into an APC battery backup. Using the same GCODE that was saved in Octoprint, the print came out successfully!

Just for grins, I may try again, this time re-enable the Spaghetti Detective to see if it was the power.

This is a new house and my printer is in the laundry room and I don't know if what caused the random crashes might have been related to slight brownouts, or the dryer kicking on or what?

I'll mark this as solved and if someone has random weirdness it just might be the power supply or maybe in my case the power coming into the power supply so the battery backup helped?