Octopi @ Raspberry 3B+ and 3.5" Touch screen will not start desktop enviroment

Hi all,

I am quite new here at the board.
Got some expirience in 3D printing.
I was running octopi at an old RasPi A ... it did his job.
A few weeks ago I swapped to a RasPi 3B+ and it worked fine as well.

NOW ... I purchased a 3.5" Touch Screen as bundle with a new case.
Mechanically it fits well ...

First startup was only a white screen ...
I figured out how to install drivers and stuff.

The next boot was successful ... I got a login prompt at the screen.
Now I found out how to auto-log in ... BUT ...

... now I need your help.
Octopi starts up and shows the default "no desktop enviroment installed" message.

I used the recommended prompt to install it:
sudo /home/pi/scripts/install-desktop

BTW ... I am connected via SSH-SHELL and my computer's OS is Linux Mint.

Running the prompt turnes out some questions which I answered correctely:
"any key"

A long installation process began ...

Final msg:

--- Setting up Pi to boot to desktop
--- Done!
You might want to reboot now: sudo reboot

While reboot the pi obviously tries to bring up a different (white) screen and falls back to an undefines state with a no-blinking cursor at the upper left corner.

Long story I know ... can anybody help me?

Thanks so much in advance.

(sorry for my probably knotted English)

... oh.

I checked "raspi-config" and found out that the lowest available default resolution is 640x480.
My Display has 480x320

Any idea how to change to this resolution?


You might want to review the specifications for /boot/config.txt and tell Raspbian what resolution you're hoping for. Check the link on that page for display and review hdmi_group/hdmi_mode.


thanks for pushing me to config.txt
I'll check it at home.

I did not know, octopi is running on Raspbian OS :upside_down_face:

If I understood right I have to choose the HDMI mode?


Here is an additional page with a more detailed config documentation

Hi again,

I checked both links ...
If I am right I have to use group_2 DMT!?
But I tested mode_1 CEA as well.

In both modes I tried to get a picture running the lowest resolutions but without any visible stuff on the screen.

Any more hints for me? :expressionless:



Try that.

1 Like