OctoPi Release Candidate 0.18.0rc2 needs testers!

First of all: Happy New Year everyone!

Guy Sheffer just published a second release candidate for the next release of the OctoPi image, version 0.18.0.

Compared to the first release candidate this new one contains the following changes:

  • OctoPrint 1.5.2
  • RpiOS 2020-12-02

If you’ve been waiting for a new OctoPi release, this is your chance to give the candidate a test drive and report any findings back in the ticket on the OctoPi repository so we can make sure the release is solid!

You can find the download links in the ticket.

Confused about the difference between OctoPi and OctoPrint? Read this!

This is a companion discussion topic for the original entry at https://octoprint.org/blog/2021/01/11/octopi-release-candidate-0-18-0rc2/

Will be using this on my Ender 3. Is there anything specific we should be looking for with this RC?

Not really. It's the second RC with Python 3, so depending on what plugins you use you might have to ping their authors to finally port them over, but most are already compatible.

I want to test ist on my sapphire pro with a 7" Display, Webcam, skr 1.4 turbo on marlin 2.

1 Like

I'm interested as well. Creality Ender 3 V2.

@crystalk3r and @davev88 - no need to let us know you want to test it, the link is above - go ahead and download it and let us know if it works well!


I already used 0.18.0rc1 on my pi4 and anycubic i3 mega pro.
How can I update? Just apt update && apt upgrade for the system and then install updates in octoprint?
Or do I need to re-flash?

As with all OctoPi updates, it is a re-flash of the image. If you read the changelog you can decide if you want to update or not.

1 Like

I would put this on my pi as I am all ready running the previous version. The RPi 4b 4g seems to not like the 17 so.. haha I had to use the other, and I will have a second RPi running a second rig as soon as i get a few things straight on it. So sign me up Scotty!!


I installed the latest 64bit nightly, and struck a problem with HAProxy not starting up. I replaced the configuration with this to make it work:

        maxconn 4096
        user haproxy
        group haproxy
        log /dev/log local1 debug
        tune.ssl.default-dh-param 2048

        log     global
        mode    http
        compression algo gzip
        option  httplog
        option  dontlognull
        retries 3
        option redispatch
        option http-server-close
        option forwardfor
        maxconn 2000
        timeout connect 5s
        timeout client  15min
        timeout server  15min

frontend public
        bind :::80 v4v6
        bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem
        option forwardfor except
        use_backend webcam if { path_beg /webcam/ }
        use_backend webcam_hls if { path_beg /hls/ }
        use_backend webcam_hls if { path_beg /jpeg/ }
        default_backend octoprint

backend octoprint
        acl needs_scheme req.hdr_cnt(X-Scheme) eq 0

        http-request replace-path ^([^\ :]*)\ /(.*) \1\ /\2
        redirect scheme https code 301 if !{ ssl_fc }
        option forwardfor
        server octoprint1
        errorfile 503 /etc/haproxy/errors/503-no-octoprint.http

backend webcam
        http-request replace-path ^([^\ :]*)\ /webcam/(.*)     \1\ /\2
        server webcam1
        errorfile 503 /etc/haproxy/errors/503-no-webcam.http

backend webcam_hls
        server webcam_hls_1
        errorfile 503 /etc/haproxy/errors/503-no-webcam-hls.http

Tracked in https://github.com/guysoft/OctoPi/issues/711, OctoPi 0.18rc2 doesn't have 64 bit builds because they're not ready yet. Feel free to weigh in if you know solutions for other issues to help get this to stable for 0.19.

I changed to 0.18.rc1 a few months ago and the camera still behaves inconsistently, although not as bad as in 0.17.
Trying rc2 now.
(and I am making a wild guess here, even if the problem is still there, it will behave nicely in the 64bit version).

not sure if you'll find that to be the case.

I loaded and got in to the OS via command line, No GOOEY. Tried to install UI.. via install desktop.. and FAIL. It reboots and then Dead. Yet the Octoprint was effective before the Desktop attempt.

@jneiliii we'll have to wait and see i guess

in the meantime, the camera issue is still there.
yesterday it was fine, today the i booted the pi, no camera, reboot it was working.
but it stopped when the print started.
at least that's a hint...
(i am posting this in the camera topic too).

Hello Lazzu,

So I got rid of :
http-request replace-path ^([^\ :])\ /(.) \1\ /\2
http-request replace-path ^([^\ :])\ /webcam/(.) \1\ /\2

Then Haproxy worked as it stated that it's not compatible yet my webcam will not work. Still working on that piece.