Octopi sd full when not full

What is the problem?

Octoprint can't start, i can ssh to the raspberry and when i go for a sudo apt update i get the "no space left on device" error.
I have a 32gb card and when i run ncdu i get:

138,6 MIB - /octoprint
128,8 MIB - /.octoprint
61,5 MIB - /.cache
and some other under MIB size so the card is not full.

If i run sudo fdisk -l i get this on the (linux) partition:

Device | Start | End | Sectors | Size | Type
/dev/mmcblk0p2 | 532480 | 62521343 | 61988864 | 29,6G | Linux

If i run sudo df -h i get this:

Filesystem | Size | Used | Avail | Use% | Mounted on
/dev/root | 30G | 29G | 0 | 100% | /

What did you already try to solve it?

sudo raspi-config and expand filesystem
Tried deleting all i could but it still says full.
Tried stopping and restarting the daemon and services to see if they held on to files that couldn't delete but the commands from above says otherwise

Linux boots just fine but it seems like a faulty card or some other error?

All the logs for serial and octoprint are blank so nothing there...

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Impossible to provide this since i can't get octoprint to start?
The commandline only gives me:

Could not initialize settings manager_ [Errno 28] No space left on device
There was a fatal error in initializing the platform

but it says this in the beginning atleast:

OctoPrint version : 1.7.2
OctoPi version: 0.17.0

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 pro, Octopi on a raspberry pi 4 with a 32gb sandisk ultra sd card using wifi

1 Like

I am not intimately familiar with ncdu, but it looks like you only asked it to look at the current directory, which seems to be /home/pi. The 'df -h' output clearly shows that there is no available space. Something outside of `/home/pi' is taking up around 29 GB of space.

You can probably run ncdu / to get the disk usage of the root folder, instead of the current folder. Otherwise sudo du -hs / should let you do that.

Are you using octolapse? It fills the SD card with images and I have yet to see it actually clean it's.own directories. Uploaded gcode files can add up as well.
Also, sudo du -sh /var/log

3 Likes

If I could bet on it, I'd put a lot of money on two fairly similarly sized syslog and kern.log files that take up all available space on the SD card, filled with WiFi errors.

3 Likes

Yes, THANK YOU! the logs is humungus hehe can i just emty the folder? or do i need to keep some that doesn't generate?

Deleting the log files shouldn't cause an issue - I've never seen a report the problem comes back again - it seems to be fairly random when this happens. If you haven't already since flashing OctoPi, run sudo apt update and sudo apt upgrade to make sure you have the latest WiFi firmware.

3 Likes

Thanks for all the help, works like a charm again :ok_hand:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.