Octopi server running cannot login on to pi

issue: i have installed octopi and octoprint accordingly. I am running a raspberry 3 b+ with 3.5 lcd. octopi ver. 0.17.0 octoprint 1.4.2 connected is my Anet A8 Plus. I have usb web cam as well. all of it is working... Accept yesterday I tried to clone my micro ssd 16 gb sandisk. since then the pi starts up in octopi, all good. I have he ip address (former admin) i get the login box asking for user and password. I know mine (writen down lol) I tried pi and raspberry with same results. I have been searching for hours to find where or how to fix this issue. I have putty buy ssh connection is same problem. I am getting a litter frustrated, I can not be the only one that has every had this issue?

What did you already try to solve it?

reboot, putty login, ip address check, router connection check, wifi connection. ensured all devices where connected and on. ie.. video cam, keyboard, printer via usb.

Complete Logs

tell me how to get them when I cannot login and I would gladly provide them. new to octopi.


I hope I covered that in the intro. I am hoping that this is an easy fix. it took two days to get all this working and one minute to kill it.

Respecfully any help would be appreciated. i will do my best in the future to include items as you listed. thanks for your time. Vic

Hallo @darkrider!

As you see, the word Logs is in blue: It's a link :wink:

Thank you, I appreciate you getting back to me. Looking at the documents about the logs now. I will follow up once I am familiar with them.

well I was unable to follow how to get the log files. ssh and winscp are the same difference. I cannot log onto the server (pi) octoprint to get them either. which is what the problem is. the ssd does not contain any log files windows appdata does not exist anymore as I can see.. looking like my only choose is, reload it or forget it... everything points to an unstable situation, I don't have the time to constantly worry weather or not this platform is going to load and run.. a hobby yes, a career I already had one.. this is suppose to fun, educating but most of all doable...maybe next year I will think about it again. for now my printer runs gret and I can load files no issue... thanks for your time..

@darkrider When you say

Which login box do you mean?
The one visible at the IP address, like here

or the one on the command line, here

If you cannot get into the Pi, logs will not help since you cannot get in :slight_smile:

If you have an issue with forgetting the password to the first one, it is possible to reset from command line. Note this one is NOT pi and raspberry.
With the 2nd, the default is username: pi and password raspberry, or it may be different if you changed it, in which case I hope you have it written down.

Hi Charlie, Thanks for chiming in on this issue. I cannot log into either the pi or octoprint. The octoprint server is running. I get the same credentials problem weather I try to SSH or WINscp. I tried to do a new install yesterday, new ssd sandisk 16gb followed all the steps, installed no problem. After restart I ran into the same issue. It changed it’s ip which was corrected. And it can see the pi and communicate it just will not allow a connection with any credentials. Unless I am missing some important piece of information, windows 10 does not have an appdata directory anymore. I enabled all folders and file to be seen by permissions and it’s not there. I even did a run command and tried changing directories by typing it the old way.. my question is why is it locking out it’s administrator.. No back door to setting the password. ?

I read about 4 hrs of the forum looking for a resolution to this and it’s all the same answer. It’s your connection. Well I know it’s not the connection…. So I am left with that same feeling, is this worth it?. Just as a ref, I used to run black box server and redhat. Former windows admin. It’s been years but I can still follow direction quite well. That’s my story and I am sticking to it.. lol I am in this for the education and a bit of fun along the way. Would be nice if this would work. Thanks again for getting back to me and of course I would greatly appreciate some poniters in the direction I need to take.

If you've installed it on the raspberry pi, nothing will be in windows, except your browser - everything is done on the Pi. So you have no OctoPrint appdata folder, (which if installed on Windows is usually under C:\Users\You\AppData - it does exist still, but is usually hidden - you have to check show hidden. Anyway, that's irrelevant I believe.)

You would have to SSH into the Pi to find all of this data - stored under /home/pi/.octoprint - on a brand new install this would be with the username pi and raspberry, unless you have changed it.
To SSH in, open CMD/Powershell/GitBash etc., and run ssh pi@<pi's IP>, eg ssh pi@ Note here that the password to SSH in is DIFFERENT to the password used to log into OctoPrint. This should work regardless of restart - if it doesn't then that seems some kind of issue with the machine - since it works everywhere else.

When you set up OctoPrint, do you set up Access Control, as in the screenshot?

If you did, then it is with the password set within the OctoPrint UI, not on the command line.

You can set up OctoPrint to not use a password, although that means anyone on your network is able to access it.

Let me know the answers to the above, and if you have specific questions I can try and answer.

HI Charlie, I followed your instructions on the login info. I was able to locate appdata. But most important I can log into my pi and octoprint now. Thank you very much for the understanding and patience. I apparently installed everything on the pi not my pc. So appdata was empty, almost through me. But I read very carefully what you wrote and understood the difference in the install. I am back with the octoprint followers/supporters..

Thanks again…

Excellent, glad I can be of use. OctoPrint is great software, you will have fun using it!

Edit: if you could please

Means other users who come across the problem know it is solved, thanks!