Octopi SSH working for around 2 minutes before disappearing after I restart my laptop

What is the problem?

Hi guys, I am new to the Raspberry Pi and Octoprint and I am having trouble setting it up. I have got to the part of actually connecting it to my laptop via SSH however after a few hours, I couldn't get it to work.
I found that restarting my laptop seemed to temporarily fix it and it worked for around the first 2 minutes of my laptop booting up before it went back to not being recognised.
I'm beginning to wonder whether there is some program that's blocking access from my laptop to the Pi that's starting up 2 minutes after booting up, but not sure how I can find this out.

Would appreciate any help, thanks in advance!

What did you already try to solve it?

I've tried the following:
-Disabling my antivirus (Norton).
-Reflashing the microSD with Octopi and redoing the whole process again.
-Connecting the Raspberry Pi to a screen and checking for updates and ensuring SSH is enabled.
-Checking the startup programs and closing them to see if they affected it.
-Connecting the Pi to the router via Ethernet (can't see this helping as the issue seems to lie between my laptop and the Pi, however my laptop doesn't have an ethernet port)
-Installing Bonjour for PC
-Using Putty to SSH however I get the error message "Host does not exist"

I have tried it on a desktop PC connected to the same WiFi network and that seems to work fine, just not sure why it's not working on my laptop.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

When I try to access http://octopi.local/ I get the "This site can't be reached" page and when I try accessing it via Command Prompt, I get: "Could not resolve hostname octopi.local: no such host is known"

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Pi: Raspberry Pi 4B
Laptop and desktop OS: Windows 10
Browser: Google Chrome

Try http://octopi or http://theIPofthePI

Maybe that helps :slight_smile:

Hi, thanks for your response, just tried this. Both take me to a login page, but I tried entering the username (pi) and password to the pi, but it keeps saying that they are incorrect. I tried this on the other desktop as well and I get the same response.
I have signed into the pi on my other desktop through CMD and through the pi itself by connecting a screen to it and they both accept the same username and password so I know that they are correct.

Are we confused here between SSH and the OctoPrint web UI?

SSH (the text-only terminal) the default username/password is pi/raspberry.

The web UI login (for OctoPrint) takes whatever username you might have configured.

Just figured it out literally 2 seconds ago, I was indeed confusing the two, thanks @PrintedWeezl!
It seems to be working now thanks - Google's Autofill seems to have saved me haha.

Any idea why it's not letting me SSH into it?

What happens when you try to SSH into it?

I get the message "Host does not exist" when I try it in Putty. When I try using command prompt (ssh pi@octopi.local) I get "ssh: could not resolve hostname octopi.local: No such host is known."

Do you know if there is any upside/downsides to using the links you sent compared to SSH'ing into it?

The upside would be that it works :smiley:
No downsides. Those are just different ways to connect to the same device.
The ip address should always work.

When you attach a HDMI monitor/TV to the Pi, do you get the complete boot-up sequence?

Yup! Only part that fails is the webcam but that's expected because I hadn't connected one.

At the end of this sequence there is an IP address.

Try connect the Pi with that instead with http://octopi.local.

Haha I can live with that!
Ahh okay, that's good then, I'll just use it this way. Was wondering whether there would be a security risk of doing it this way, but it's all good then.
Thanks for the help!


Yup, I believe that's what @PrintedWeezl said earlier.
Seems to be working, thanks!

There is no more risk by using the IP than using octopi.local