Octopi stops working out of nowhere

What is the problem?

Every time I try to log in to octopi.local, it doesn't work and gives me this message

What did you already try to solve it?

I tried rebooting it, checking all the wires, everything I can think of...

Have you tried running in safe mode?

Don't know how to run in safe mode if I can't get onto Octopi :stuck_out_tongue:

  1. Have you tried accessing it using the direct IP-address? It may be that your local DNS resolver on the network may have issues with the "octopi.local" address and tries to resolve it using a regular DNS resolve which will fail.
  2. Have you tried giving your Rpi a static IP address on the network? it may be that your computer's DNS cache is trying to access one of it's previous IP addresses if it's not a static IP and the DHCP server has released the IP and assigned it another.

By the looks of the error you get, it's a DNS issue "DNS_PROBE_FINISHED_NXDOMAIN", so try the above steps.

If you are running windows, you can also try these steps:

  1. Open a console (Preferably with admin privileges)
  2. Type: ipconfig /flushdns

and try again.

I think OctoPi is still working just fine, just that your connection to it isn't.

Yeah, I've tried the IP, but can't find it. I've been having problems with the IP changing sometimes too. The router say it's 'offline' when it is definitely online, which either means the connection sucks, which doesn't make any sense, since was working fine just before, the wires are having a problem, but that's not the problem, I checked that already. I'll try giving it a static address and see what happens then...

If you have the chance then connect a HDMI TV/monitor to the Pi.
If it runs well, at the end of the startup sequence you will get the Pi's IP address.

You have tried the IP but can't find it, you mean the IP-address or the connection to the RPi?
May I suggest giving your RPi a static IP based on MAC address?

If all else fails, connect it to the network with a cable and SSH into it, get the ip & MAC address ($> ip a) that way.

You can also, when you're SSH'ed into it, assign it a static IP manually, follow this guide: https://www.raspberrypi.org/documentation/configuration/tcpip/

I've tried the IP for octopi (192.168.x.x) but can't find it there. I'll try these suggestions, as soon as I find my micro SD card for the RPi (not the one where I flashed OctoPrint) because I seem to have lost it somehow...

You need to do that on the card you'll be using, mate. If you set all that up on the RPi SD card, and switch to the OctoPi card, those settings are lost and you can start all over again.

I have the pi files saved on my computer in a folder, lucky, so I can just take the microsd with octoprint flashed in it and put the other RPi files inside?

What other files? If you want to change the config of your Raspberri Pi (with or without OctoPrint) you'll have to SSH into the Raspberri Pi with an SSH client such as Putty or Bitvise and open a console.

If you make all changes to it on your computer instead of on the Pi itself, and just copy stuff over, it's never going to work. That is not how a RPi works.

From all partitions? Also the Linux partition?

I am very new to this, so I don't know much about the Pi, hence this post. I just took all the files from the pi and copied it in a folder, no edits to the text or anything like that

I just see COPYING_linux in the file, I'm not very knowledgeable when it comes to the Pi.

At this point I would recommend to setup a new OctoPi image on a SD card.

There are two partitions on the Pi's SD card. One that you can view with Windows, one that you cannot. Unfortunately, you can't copy parts of it and instead need to use an image backup tool, or open it from a linux box or similar so that every single file is visible.

If you don't know what you are doing, don't do it. It's a good thing to go by dealing with OS/hardware/images etc if you don't want to break things. Do more research, such as backup raspberry pi image in Google and you can convert that don't know into do know :slightly_smiling_face:.