Octopi.txt empty when setting up camera

Camera model

What is the problem?
I'm trying to setup the above camera to use in Octoprint, Octoprint is all set up with Octodash.

What did you already try to solve it?
In numerous web pages I see it mention to run "sudo nano /boot/octopi.txt" and change some camera settings but this file is empty, checked also with winSCP... Before I start again from scratch, is there any idea how to get the camera working? In Octoprint it says "Webcam stream not loaded....".

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
Logs here

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Raspberry Pi 4 Model B Rev 1.1
Octoprint version: 1.8.6
Otopi version: 0.18.0
OctoDash: latest, just installed a couple of days ago.

pi@Octoprint:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I solved the issue of no camera, I started again and the camera worked initially but once complete is was disabled again. I started again for a third time and this time went step by step and I found the point at which it disables, when I ran "sudo ./LCD35-show" for the touch screen drivers, I googled that and found someone else posting a similar issue and that this for some reason turns off the camera. To rectify I went through sudo raspi-config -> Interfacing Options -> Camera -> Yes and rebooted. Camera is working now.

1 Like