OctoPi update from 1.4.0 to 1.4.2 fails

What is the problem?
I was unable to start the OctoPi server at all until unplugging my printer. Now my serial connection is down, but at least I can connect. Upon attempting to update the software to see if that fixes things, I get a message, "The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details." The log is updated immediately, but my last plugin_softwareupdate_console.log is over two weeks old. No new log of that type is generated no matter how many times I attempt it.

What did you already try to solve it?
(for serial connection) I've rebooted the router. I've cycled Pi power both before and after printer power. I'm able to ping OctoPi's IP address from another machine on the network. Ultimately disconnecting the printer from OctoPi allowed me to connect to OctoPi.

(for update) I've tried in safe mode and in normal mode. I've tried updating individual plugins and the result is the same.

Logs (syslog, dmesg, ... no logs, no support)
LOGS.zip (17.4 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Win10 laptop connecting over local network to RPi 3B. Pi issued static IP from router.


Was the printer plugged in when you ran the upgrade? It's possible the printer is drawing current from the USB port causing undervoltage, or the cable is somehow damaged.

No, it wasn't. If the printer is plugged in, OctoPrint won't start... or, at least, I can't connect to it. Consistently. I can unplug the printer and expect to connect. If I plug it in, it fails every time.

I actually battled undervoltage before and solved that with a more robust power supply. I have changed nothing in my setup since the last successful print.

EDIT: I'm going completely backwards now... can't connect the Pi to WiFi since about 6am today. I'll check to see if my PS voltage has degraded somehow when I get the chance... my Fluke died recently. After my last undervoltage problems I was able to get everything going with a buck converter outputting 5.1V.

SSH into your pi - then run:
~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint
to force a full reinstall of the OctoPrint packages.

OctoPrint does tell you if you in the UI have undervoltage issues, and the red light on the raspberry pi will flash/not be lit if there is inadequate power supply.

I may do that when I can get into it. I just set up a network repeater bridge right next to the printer so I can plug the Pi into an Ethernet port. I've got it plugged in; the Ethernet port LEDs are on solid on the Pi, but I can't see it in the LAN tab of my DD-WRT router. I can't find it at all to SSH in. I thought if I couldn't get the wireless to work, I could do it wired... but I'm getting nowhere with it.

I measured my supply voltage last night at 5.15V. The red LED is solid on. I have seen the undervoltage error with a past setup, but my problem now is I can't even get the UI up.

I thought you wrote you could ping the Pi's IP address, which implied to me it was connected to the network? You could also try ssh-ing to octopi.local as well, if you can't find the IP address easily.

If it stil doesn't want to be found on the network, you can plug in a monitor to the HDMI port and you should get the IP printed at the end of the boot sequence. (or not, in which case it is disconnected!)

I was able to, but no longer... for no reason known to me. Every other device on my network is working fine. I've made no changes. The printer is in an outbuilding and it makes sense that the signal would be weaker, but it's worked for months on end with no persistent issues. I have the repeater set up and can connect to the Internet through it. Pi is hardwired to it and isn't showing up in the device list. No idea what's happening.

I did try octopi.local earlier, but it didn't come up.

I may try the monitor route, thanks.

1 Like

Some "repeaters" may act as their own router and give an ip address internally that are NAT'd to the main wifi in your house, in which case you won't see that IP address, only the address of the repeater on your DD-WRT router. It all depends on how you configured your DD-WRT devices to talk to each other I think. Sorry, it's been a long time since I've dealt with DD-WRT and this may not apply nowadays.

Well, I just brought the Pi inside the house and powered it up. It won't connect to my network. I've checked the octopi-wpa-supplicant.txt file and it's exactly as I left it. My guess is either something's corrupted or there's a Pi hardware problem. I'm going to start from zero and see if I can get it working.

Potentially corrupted SD card due to power loss maybe.

Maybe. And I don't have another one laying around...

However, I've made some progress. I reflashed the SD card and now I can SSH into it. Now I have to remember all of the plugins I had...

It's still inside and not connected to the printer, so that's the next step.

EDIT: I spoke too soon. I got as far as installing the Octopod plugin and now the OctoPrint service won't restart.

Nope. It was running long enough to install a couple of plugins but now it won't restart... even after a reflash. This is all I get:

Worth trying a new SD card?

Have you tried those commands listed on the warning page and grab your octoprint.log file? If it happened right after the OctoPod plugin then I would suspect that might be the culprit, but it's hard to say. The log will reveal more hopefully.

Thanks for hanging out in this thread--I appreciate the help. Ultimately I found another SD card in the bottom of a bag and tried that. This makes me happy... I just hope it holds up.