OctoPi WiFi/network connection troubleshooting megatopic



I have wifi/network troubles. 2 days ago my onto(0.15.0) stopped responding. I plugged to tv and keyboard. Octo can ping other hardware in my network, it's connected with wlan. Also wget localhost worked as expected. From my pc I can't ping nor ssh, I tried the ip and octopi.local. Nothing works

I erased and installed a brand new octopi (0.15.1) I was still unable to ping nor ssh it. I rebooted my routed and even reseted the DHCP. I can see the router giving a new ip to octopi, and the octopi can ping all the hardware. The octopi doesn't answer, not to my pc, nor my phone, nor my iPad, nothing, no answer.

What can I do ?


On both your Raspberry Pi and your workstation, run ifconfig and copy the outputs here.

  • You indicate that you can "ping other hardware on my network" from the Raspberry but you didn't indicate that you can ping your workstation.
  • It's entirely possible that ssh isn't yet enabled on the OctoPi instance so keep things at ping for the moment or to attempt to connect to the http://octopi.local web interface from your workstation.
  • You didn't indicate how you installed OctoPi. Did you follow the instructions?

It's likely that your router two days ago expired the DHCP lease for your original installation. At this time, it then issued a new IP address. Your workstation probably had the old IP address in its ARP/DNS caches and got confused.


From Octopi I can ping the router, the nas and the switch, but it doesn't ping my laptop nor my wife's(MacBooks). The laptop cannot ping the octopi. My wife's computer cannot ping the octopi. My laptop and my wife's laptop can ping the router, the nas and the switch but not the octopi. My wife cannot ping my laptop nor my laptop cannot ping my wife laptop (MacBooks). I also tried loading the octopi webpage(using the ip adress) from my iPhone, from my wife's iPhone and from my iPad. All of them without success.

Please be aware in my house I have 1 router, 2 access points, 1 NAS, 1 switch, 4 laptops, 2 raspberryPi(not octopi) several iPads and several phones, all of them work, and all of them can ping each other(not the MacBooks, they don't answer the pings).

In the end it would seem as if the octopi can communicate with everyone but not answer anyone as if it was behind a personal firewall forbidding any communication.

I did install octopi(on my 3rd raspberryPi) following the official instructions and etcher. I have used octopi for the last 4 months without problems.

edit: I putted a dietpi os on the raspberry. It's having similar behaviour. I can connect to the rasp throught ethernet but the wifi seems blocked/unresponsive. In any case the trouble is not provoked by the octopi itself, but network or the wifi card on the pi. I will do other test to troubleshoot.


What is the problem?
I can't connect to my Raspberry Pi 3B+. Putty gives me "timed out connection", typing IP into a browser gives me "cannot load a page".

What did you already try to solve it?
My problem seems a little strange. I've enabled SSH in config, there are both laptop and the raspberry connected to the same ethernet network, (nevertheless I changed also credentials for a wifi but anyway), command prompt on windows gives me pings from an raspberry IP (I checked IP through connecting raspberry to the monitor).

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint 0.15.1

What's the diffrence between Octoprint and Octopi versions?

Prusa i3 mk3, newest 3.3.1 firmware

How to get logs if I can't connect is it possible?



Obviously the IP does not match.

With a fresh installation you should connect with "octopi.local" as address in putty and the browser.

OctoPrint is the server that send the data to the printer. Recent version is 1.3.9

OctoPi is a bundled installation file that contains a light version of Raspbian OS and the OctoPrint server. Recent version is 0.15.1

You also may have a look at this.


@Drake_Coldwinter This would really help. Please provide the output from the command on both your Raspberry and your MacBook.


@rocendroll In a case like this (where nothing can remote into the Raspberry), I usually try one or some of the following:

  1. Connect a monitor/keyboard/mouse to the Raspberry Pi and boot it up. Run an ifconfig to verify that either the Ethernet or wi-fi adapter has been given an IP address. Run sudo raspi-config and set the timezone and country, rebooting. Verify that the wi-fi zone isn't hidden by your router. Make sure that the wi-fi credentials were exactly correct, to include capitalization.
  2. Add an Ethernet cable and try to connect that way.
  3. Use your router's administrative console to determine if the Raspberry Pi has been issued one or more addresses.
  4. Review the LED status for the wi-fi connection in the corner of the Pi.

You can get some details in this troubleshooting guide which I created.


My laptop

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
        nd6 options=201<PERFORMNUD,DAD>
        gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
        stf0: flags=0<> mtu 1280
        XHC20: flags=0<> mtu 0

        ether b8:e8:56:43:50:30
        inet6 fe80::4f9:6452:6977:8017%en0 prefixlen 64 secured scopeid 0x5
        inet netmask 0xffffff00 broadcast
        nd6 options=201<PERFORMNUD,DAD>
        media: autoselect
        status: active

        ether 0a:e8:56:43:50:30
        media: autoselect
        status: inactive

        ether 36:a7:88:53:a4:06
        inet6 fe80::34a7:88ff:fe53:a406%awdl0 prefixlen 64 scopeid 0x7
        nd6 options=201<PERFORMNUD,DAD>
        media: autoselect
        status: active

en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500 options=60<TSO4,TSO6> ether 72:00:00:42:48:40
        media: autoselect <full-duplex>
        status: inactive

en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500 options=60<TSO4,TSO6> ether 72:00:00:42:48:41
        media: autoselect <full-duplex>
        status: inactive

        options=63<RXCSUM,TXCSUM,TSO4,TSO6> ether 72:00:00:42:48:40
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0 maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
        member: en1 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 8 priority 0 path cost 0
        member: en2 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 9 priority 0 path cost 0
        nd6 options=201<PERFORMNUD,DAD>
        media: <unknown type>
        status: inactive

utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000
        inet6 fe80::5f60:5418:b1fe:44ac%utun0 prefixlen 64 scopeid 0xb
        nd6 options=201<PERFORMNUD,DAD>
        utun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
        inet6 fe80::b51:16e6:c8ef:d8a5%utun1 prefixlen 64 scopeid 0xc
        nd6 options=201<PERFORMNUD,DAD>

RASPBERRY(I can shh and ping with wired connection(

enxb827eb022c1f: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::1a58:7bc7:912:c714  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:02:2c:1f  txqueuelen 1000  (Ethernet)
        RX packets 2412  bytes 354186 (345.8 KiB)
        RX errors 0  dropped 19  overruns 0  frame 0
        TX packets 363  bytes 63970 (62.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 70  bytes 18350 (17.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 70  bytes 18350 (17.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::4148:11dd:7b74:403f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:57:79:4a  txqueuelen 1000  (Ethernet)
        RX packets 5  bytes 1009 (1009.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 106  bytes 28535 (27.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Something strange, if I plug the network wire both ip's work ( and if I unplug the network wire nothing works...



Now that I've formatted your output with backticks (three to start, three to end), it now looks a little easier to analyze.

Your MacBook has the following bound IPv4 addresses:

  • en0: with a netmask of /24 broadcast (presumably wi-fi)

Your Raspberry Pi has the following bound IPv4 addresses:

  • wlan0: with a netmask of /24 broadcast (wi-fi)
  • enxb827eb022c1f: with a netmask of /24 broadcast (presumably Ethernet but this is the strangest device name)

On the Raspberry, are you using an Ethernet network dongle or an additional wi-fi network dongle (USB-based)? That device name is just unreal for want of a better term.

Initially, it looks good. The netmask/broadcast address for each look reasonable.

On the MacBook, netstat -nr|grep default|grep -v "::" should indicate your MacBook's default route in the second column which ought to be something like for your router (assuming that this is its address). If it's instead the IP address of one of the access points then this is probably a setup problem with your network.

Similarly on the Raspberry, netstat -nr|grep UG should indicate its default route in the second column. Again, it should be in your case. I'm guessing that this one is correct.

As for that odd-looking device name, it's possible that this got toggled in sudo raspi-config -> Network:


From your add-on message, if the Raspberry Pi's Ethernet device has a default route set (but not the wi-fi device), then it could work in the way you described.


Well it's something related to my network for sure. I installed dietpi with octo print 0.13 on a second raspberry pi, same behaviour, installed octo print 0.14 same behaviour. Reinstalled octoprint 0.15 and rebooted everything in my house (switch, router, nas, access point) and suddenly it works again. The wifi is responding I have the web page octopi.local, everything works as expected. Problem solved?

Edit: I lost contact again with the pi :frowning: problem is back (currently it's printing, but I can't access it)


@Drake_Coldwinter Yes and no. If you're into troubleshooting things, you might look at the DHCP lease length that your router is handing out (or the access points themselves). It's possible and even likely that your leases were causing you these troubles.


DHCP Lease time 1 hour. What should I put ?


Just got the record, those version numbers up there were those of OctoPi (the SD card image including OctoPrint, among other things).


Assuming that your home network has less than twenty devices within approximately 250 or so unique addresses within a Class C, you could easily set that to 30 days.

A one-hour DHCP lease is what you'd have in a typical coffee shop where you need to quickly recycle the same set of addresses over and over during a typical 8-hour shift.


[Solved] Using gnome-disk-utility 3.26.1 to flash OctoPi 0.15.1 with Ubuntu 17.10

When I diagnosed (i.e. with a keyboard and screen) the Pi 3B+ with sudo iwlist wlan0 scan | grep ESSID, it discovered the wireless access point, yet ifconfig wlan0 showed that no address was obtained despite having configured the network in /boot/octopi-wpa-supplicant.txt.

I just wanted to share how I solved my own problem, essentially by re-flashing OctoPi, on Ubuntu 17.10 / Gnome, Wayland. What I noticed as a red flag initially was a filesystem owned by root. Files in /boot didn't allow themselves to be edited as user.

  1. Installed gparted sudo apt install gparted
  2. Ran gparted xhost +si:localuser:root && sudo gparted
  3. Selected /dev/mmcblk, erased all partitions on microSD
  4. Went to Device > Create Partition Table > msdos
  5. Ran gnome-disk-utility, Menu>Restore File> 2018-04-18-octopi-stretch-lite-0.15.1.img
  6. Waited 2 minutes to write, then reinserted/remounted
  7. Uncommented lines in /boot/octopi-wpa-supplicant.txt and added network information
  8. Used a Leviton 3.6A USB outlet and a thick PS4 cable to suppress low power warnings
  9. Inserted the card/filesystem into the Pi 3B and plugged it in
  10. Installed an IP discovery tool to avoid diagnosing the IP address sudo apt install nmap and found the IP address remotely nmap -v -sn 192.168.x.0/24 (found 'x' by running gnome-control-center > WiFi > Details > IPv4 Address) and ssh'd into the pi


@Jordan That sounds a bit like overkill to me. The first installation was likely missing something in the area of wi-fi setup. For example, the country code needs to be set and before the network paragraph in octopi-wpa-supplicant.txt.


I got mine to work finally , I connected the internet straight from the ISP WIFI/Modem box into the NightHawk instead of the ISP WIFI/Modem>Switch>Nighthawk then connected my switch to the ports on the back of the Nighthawk . I can access through WiFi now through any device but order for me to access it through my main desktop(LAN) since its on a different network I would need to disconnect it from the ISP box instead, into the Nighthawk or the switch, which isn't hard but I'm too lazy but I think I'd solved it.


I'm still having troubles. If I reboot the octopi and the router, then just afterwards my laptop may connect (or not, doesn't always work) to the octopi web page (using ip only). Then a few hours later it will simply not work. I have set the dhcp lease to 70 days and I tried to enable the dhcp on my switch(disable router dhcp) but it was still not working at all. :frowning:

I have been reading that if other hardware on the network uses a .local adress then it can cause troubles. I have my NAS who uses http://wdmycloud.local can it be the source of the troubles?


@Drake_Coldwinter I don't think your NAS is the problem here, to be honest.

Possible reasons

  • If two devices on your network get the same IP address then oddness like this can occur (intermittent connectivity).
  • If any of your devices have the wrong netmask set, it can be problematic.
  • If any of your devices have two network connections and a default gateway set for more than just one adapter, then it can cause problems.

Sometimes helpful

  • Issue a static IP address to your Raspberry Pi by its MAC address in your router
  • Add an entry into your workstation's /etc/hosts (Linux), /private/etc/hosts (OSX) or C:\Windows\SYSTEM32\drivers\etc\hosts (Windows) file for your Raspberry Pi. This reasonably cuts out DNS, NETBIOS and Bonjour for name resolution.
  • ping octopi.local should make sure that its entry is in your local ARP cache, helping things.