OctoPi WiFi/network connection troubleshooting megatopic

Got a problem getting the WiFi connection to work with your OctoPi install?

First of all, read this FAQ entry that should already take care of the most common issues:

If this doesn't help you, use this thread to ask for help. Include the results from the diagnostic steps outlined in the FAQ entry or it's unlikely that anyone will be able to help you!

Please do not open a new topic on your problem but instead use this one - we already have enough "My WiFi doesn't work" topics, and it gets a bit repetitive :wink:


Hi there, I am currently running OctoPi on a Pi Model 3 B. We recently moved ISP from TalkTalk to Virgin Media with the Hub 3 Modem/Router combo.

We keep getting dropouts on the router which disconnects all devices and when the router is rebooted everything reconnects automatically... except the Pi.

I have tried the solution found here:

But after rebooting, confirming the Pi is connected and OctoPrint is accessible, if i reboot the router the Pi still does not automatically re-connect to eh network.

This leaves me with a problem when the network drops during a long 10 hour+ print when i can't connect to it to monitor it via the connected v2 PiCam as the only way to get the connection back is to force reboot the Pi via the inline power button on the power adaptor and that would obviously stop the print process.

Any help in this matter would be greatly appreciated.

Note: I am using the built in WiFi-Chip on the Pi.
Also, i have no idea how to find out what version of OctoPi i installed. I can access the Pi through SSH if i need to put a command in the console to get this information.

The printer is an Anet A6 connected directly to the Pi 3 via USB.

Another issue i have had since we got the new router is connecting to the OctoPrint server via the local host name address. It worked fine on the old TalkTalk router but with the new router i can only access it via it's local IPv4 address. I have checked the connected devices in the routers control panel and it does show the correct host name that i set on the pi but i cannot connect to it via .lan or .local

Thanks in advance for any provided assistance


Edit: Just wanted to add another quick question if i may. Is it possible for me to update to the latest version of OctoPi without re-flashing the entire MicroSD card and starting from scratch? Thanks :slight_smile:

Are you able to connect a keyboard & monitor to your Pi? It might be necessary to do some diagnostics once the issue arises.

Also: What version of OctoPi is this?

No, sorry.

That's unfortunate. Is there some way i can export my configuration so i can re-flash and then just load in the old configuration on the new server install?

I can SSH to the server for putting in commands no problem.

I did state in my original post that i don't know how to check what version i have installed. Where do i find this/what commands do i need to put in the terminal to get this?


The FAQ and search are your friends when it comes to answering these kind of questions :wink:

Hey all, so i got a Raspberry Pi 3 B+ and installed octoprint, over ethernet it works great but i cannot get it to work on wifi, i seem to have this same problem with every raspberry pi ive ever use, i normally eventuallly get them to work but ive spent hours on this and still no joy

ive followed the standard settings for wifi, heres my config below (all details included because you dont know where i am :wink:

##WPA/WPA2 secured

i tried iw config eand tried looking for available networks but it was like it didnt realise wifi was available

any help appreciated

I got the wifi to work initially following the instructions for octopi but it would not stay connected even with the thing in front of the router.. I gave up and ran a cable. Sorry not what you wanted to hear.. and not really helpful
I did make these duhickys to hold the cable to the base boards :smile:
.cat5 hold down.stl (585.2 KB)

my raspberry pi 3 had same issue but only when i tried to connect from a 2nd device, i find pi's so frustrating, youd think with such a large community it would just work but nope

cant really run a cable where the printer is, i could try some over those ethernet over powerline plugs but id really like to get wifi to work, ive ordered an official pi wifi adapter to see if that helps

I wrote both a troubleshooting guide and another for name resolution hacks. It discusses things you might not have done, like setting the country code, for example.

Specific sections can be linked such as:
My wi-fi zone is hidden

I've got a Pi3 Model B running octopi 0.15 and have been unable to connect to my WiFi. It's broadcast by a DLINK router configured as an AP, with WPA/WPA2 passkey.

I started by just configuring the /boot/octopi-wpa-supplicant.txt file by commenting out the WPA section and plugging in my SSD, and switching the country code from GB to US.

Currently, both /boot/octopi-wpa-supplicant.txt and /etc/wpa_supplicant/wpa_supplicant.conf are set as:


 ssid="Network Name"

I don't get an IP if I run ifconfig wlan0, even after reboots and disconnecting the ethernet cable that I am using to ssh in for the time being.

Edits to config files have been made by sudo nano

I've jogged through the FAQ and nothing has helped so far. I also tried escaping special characters in the passkey to no avail - i'm unsure if that is even necessary.

Any help getting this straightened out would be greatly appreciated, I feel like i've done all the possible google digging I can at this point and spent hours trying various configurations.

1 Like

Capitalize "US" there in the country code section and try that.

I'll give that a shot. Any idea if I need to escape spaces or special characters in the config? I would think the quotations would achieve the same effect but i'm unsure, and it takes a while to test every previous configuration when I make a change.

I would guess that a quote character (") is possibly the only one you couldn't use in this context for either SSID or password with respect to the underlying Python.

From Cisco's website:

The SSID can consist of up to 32 alphanumeric, case-sensitive characters. The first character cannot be the !, # or ; character. The +, ], /, ", TAB and trailing spaces are invalid characters for SSIDs.

It appears to be best practice not to use any of these characters in wi-fi passwords:


I'll add to this that using a backslash also is known to cause problems.

I can login octopi from another machine via IP address however Octopi fails the connectivity check. I also cannot update or turn on VNC so I can access the headless pi.

Newest version of the octopi image is running. Accessing via a Mac and running a Pi version 3 b+

You already have a topic here with the same content. Please keep it to one post.

New user here. Just got my first Pi 3 Model Bs and I'm trying to set up two of them and I'm not having any luck with either one. I've gone through the troubleshooting section, but I can't get these things to even get past the boot stage, let alone talk to my router. I've tried 3 different SD cards (2 Sandisk Ultra 32 and a generic 16) all with 0.15.1 burned to them with Win32 Disk Imager. I edited the octopi-wpa-supplicant.txt with Wordpad ++ exactly as directed to enter my SSID and passkey, and then changed the country to US. Saved and then used the eject function before removing. I hooked up a keyboard and monitor and this is as far as the bootup would get. It will take no intput from the keyboard. Can anybody help? Thanks in advance.

My guess is that you've formatted the microSD card rather than using Etcher, for example, to burn the entire OctoPi image to it.


I used Win32 Disk Imager (as I mentioned). This was mentioned in a few of the tutorials as an acceptable way to burn the image. I'll give Etcher a try just to make sure it's getting burned correctly.

Well, not sure why the Win32 DI burn didn't work, but the Etcher burn seemed to have solved my issues. Thanks for the help!

1 Like