Octopi wont boot to destop

What is the problem?

I recently installed Octopi on my Raspberry Zero W when I get to the promt if I want to start to desktop and I eneter "yes" it acts like it is installing packages, tells me to reboot and when I do It just pulls up the command promt. I am using the nightly from 2 days ago

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


To be sure there is no a fault with the Pi, I recommend to use a stable version of OctoPi.

1 Like

What 'prompt' have you answered? What are you trying to run?

By default OctoPi does not have any desktop installed. You must be running some script/program that is providing this prompt - what is it?

I guess you didn't activate the boot to desktop option.

But you won't have a good time with a pi zero in desktop mode.
It's barely able to run octoprint in console mode - in desktop mode I can guarantee you that your printer will at least stutter or even freeze for seconds while printing.
And besides that it will take ages to boot and will be reeeeaaallly slow.

1 Like

Thanks. I got to raspi-config and found the boost option in said to run ' suddenly apt-get install lightdm' I did. Tried setti g boot to GUi and get this[quote="Steven, post:1,

Sorry all new here and ti raspberry. So until I get a wifi adapter moved on to trying to install on am old laptop. After I burn image to an USB drive and set laptop to boot from it all I get is a blinking cursor in upper left hand corner. Also tried the same sd card with adapter I used on my pi amd it won't boot either. Can't put my finger on what I am missing. Been many years since I really messed with computers. Like 15 years

It looks like your 1st reply here got cut off part way, so we didn't get all that information.

OctoPi will only work with Raspberry Pi boards. It won't work at all on anything else, so not sure what you are trying to do here. If you wanted to install OctoPrint on your laptop then you have to do so manually, there are no pre-configured OS images available.

As you say you're all new to raspis and stuff and may well be expecting things to go differently:
Raspis may or may not be running a graphical interface ( I have 5 here and none of them has a monitor or keyboeard attached). Raspis running octopi and octoprint on it to be a print host most usually do not have a desktop etc, they run 'headless'
You interact on 2 channels: The browser (pointing to octopi.local ??cannot check as I do not use avahi here) which connects to the web interface of octoprint. And ssh (secure shell) which lets you log into the box from remote, like, from the other room, from your pc. In case you run windows, putty used to be a fine choice for sshing into linux boxes. What ssh gives you is a shell, a console window into the linux box. Steep learning curve at first but it is rather powerful.

As to the raspi zero, as @PrintedWeezl already wrote, it's not the best choice. Not even a good one. It simply lacks the ressources to perform the tasks you want from your print host. Get a raspi 3B and a decent usb power supply (2.5A or better even, 4A)

1 Like

Thanks for all the help, Sorry I haven't been back in a couple days just finished up a 3 week straight run at work. I did away with the Pi Zero and did an install on windows. I have the server up and running fine, however I can't access it from any computer or 3rd party app. All the I addresses I can find, I am trying to run it on a wireless LAN, come back server not found. Any suggestions or ideas would be great. It is driving me insane LOL

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.164 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1501
env.hardware.ram : 8427769856
env.os.bits : 64
env.os.id : windows
env.os.platform : win32
env.python.pip : 21.1.3
env.python.version : 3.9.6
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.6.1
printer.firmware : Marlin Ver
systeminfo.generator : systemapi